Ask Your Question

Unable to reconnect to a WiFi network on Fedora 20?

asked 2014-01-05 18:17:23 +0000

jflory7 gravatar image

updated 2014-01-12 09:00:59 +0000


After leaving my Fedora 20 laptop running overnight, I open it back up and it prompts me to re-enter the password for my home WiFi network. The password is already typed in and censored, but it wants me to to confirm and hit Connect.

I have deliberately made sure the password I am typing in is correct.

Once I type the password into the prompt, I press Connect and the prompt disappears. About five to ten seconds later, without displaying an error message of any sort, it brings up the exact same prompt with the password already entered. Just to be sure, I've tried just pressing Connect without editing the password, and I have also retyped the password and tried again to no avail.

Guaranteed Fix

As of right now, the only way I know I can indefinitely fix the problem is by restarting my laptop, which leads me to believe that either my home WiFi network is misconfigured in the WiFi Settings, or there is something that Fedora isn't handling properly.

Ideally, yes, I could just restart my laptop, but for example, let's say I'm uploading a significant amount of files over FTP, and if I restart my computer, that means I have to reupload a few thousand files because I have no idea which ones have been uploaded, which is just a huge delay.

Network Setup

My network is a Westell modem connected to an Apple AirPort Extreme router. As far as I know, it's a pretty standard setup.

The router handles DHCP and NAT, which does cause a small problem with the modem (a double NAT), and AT&T told us that if we want to use the features from our AirPort Extreme, we will have to deal with it. But it hasn't affected Internet usage on any other devices for the past year and a half since we set it up.

This is the AirPort Utility's description of a Double NAT, if it helps any:

This AirPort base station has a private IP address on its Ethernet WAN port. It is connected to a device or network that is using Network Address Translation (NAT) to provide private IP addresses. Change your AirPort base station from using DHCP and NAT to bridge mode.

Using bridge mode disables some of the most important features of our AirPort Extreme base station, including guest networking. But as I said previously, having the Double NAT hasn't affected Internet usage on any other device for the past two years.

edit retag flag offensive close merge delete



Issue still remains unsolved.

jflory7 ( 2014-07-12 05:33:21 +0000 )edit

2 answers

Sort by » oldest newest most voted

answered 2014-09-04 20:47:26 +0000

jflory7 gravatar image

updated 2014-09-23 13:15:54 +0000



After many months of having this issue with intermittent WiFi connections and sometimes losing connectivity for hours at a time, Bug 1108801 on the Red Hat / Fedora bug tracker seemed to hold the solution for me.

As described in Comment #12 on that bug, Realtek (the manufacturer of my wireless card) has updated drivers for my RTL8188EE wireless card that are NOT included in the Linux kernel / Fedora by default. So, my solution was to manually download the source code for the drivers, compile and install the code onto my computer, and then reboot. After doing this, I have not had any of the issue that I used to have with staying connected to WiFi networks!

How to fix

The commands I ran to install the drivers from Realtek's GitHub are as follows. Make sure you have already installed the git package from the Fedora software repositories!

git clone http://github.com/lwfinger/rtlwifi_new.git

cd rtlwifi_new


sudo modprobe -rv rtl8188ee

sudo make install

sudo modprobe -v rtl8188ee


As of the time of writing this, I haven't had more than a day to ensure that this has resolved the issue entirely for me, but it resolve the issue I was having prior to installing the driver and rebooting. I can only hope this was the final solution, but if my problem continues, I will update the question.


Every time that there is a kernel update for Fedora, you will have to download, compile, and install the drivers each time, as it only installs the drivers for whichever kernel you are currently using.

edit flag offensive delete link more


I have the rtl8188ce; will this work?

cydrobolt ( 2014-09-08 01:20:02 +0000 )edit

@cydrobolt – I'm not sure, I don't see it listed in the GitHub repository. However, you can still try and see if it resolves your issue. I'd be interested in hearing if it works or not.

jflory7 ( 2014-09-15 02:23:48 +0000 )edit

answered 2014-01-10 18:17:01 +0000

gibi gravatar image

Hi I got almost the same problem and I commented the issue https://bugzilla.redhat.com/show_bug.cgi?id=1045730 (comment 5)

I hope someone can help us; I think something must be restarted but I don't know what


edit flag offensive delete link more


Hopefully we can found out what the problem is. Fingers crossed.

jflory7 ( 2014-01-11 01:13:18 +0000 )edit

+1, filing a bug is a good idea in such cases. It sounds like the OP may have a device that does not function properly after being suspended.

randomuser ( 2014-01-11 06:57:51 +0000 )edit

@randomuser My concern with this was that it wasn't a bug as much as a misconfiguration of the hardware.

jflory7 ( 2014-01-11 19:37:54 +0000 )edit

@jflory7 Yes, I understand your concern; this answer directly addresses it: this behavior is not expected, you are experiencing a bug.

randomuser ( 2014-01-12 02:57:19 +0000 )edit

Hi randomuser and jflory; from my comment 5 of the bug I got the wifi working when I start the laptop (dell latitude d530) with just the wifi adapter on and no network cable; is there a way to reset the status of the wifi adapter on my laptop without restarting the laptop?

gibi ( 2014-01-13 08:37:49 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.


Asked: 2014-01-05 18:17:23 +0000

Seen: 3,330 times

Last updated: Sep 23 '14