Ask Your Question
1

F20: Unable to make prepare on kernel source

asked 2014-01-06 09:34:54 -0500

Aurik gravatar image

updated 2014-02-15 20:41:45 -0500

mether gravatar image

I am attempting to install the nVidia proprietary kernel module (version 319.37), and when I attempt to do so, it gives me the error:

ERROR: Kernel configuration is invalid.
include/generated/autoconf.h or include/config/auto.conf are missing.
Run 'make oldconfig && make prepare' on kernel src to fix it."

I then attempted to perform a make oldconfig and make prepare. I got the following:

[root@sager 3.12.6-300.fc20.x86_64]# make oldconfig && make prepare
scripts/kconfig/conf --oldconfig Kconfig
#
# configuration written to .config
#
scripts/kconfig/conf --silentoldconfig Kconfig
make[1]: *** No rule to make target `/usr/src/kernels/3.12.6-  300.fc20.x86_64/arch/x86/syscalls/syscall_32.tbl', needed by `arch/x86/syscalls/../include/generated/uapi/asm/unistd_32.h'.  Stop.
make: *** [archheaders] Error 2

If it is not clear from the preceding output, I am running Fedora 20 with kernel version 3.12.6.300.fc20.x86_64.

edit retag flag offensive close merge delete

Comments

Using the binary blob is not recommended. Please use the rpmfusion package.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-01-29 18:36:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-01-29 17:59:41 -0500

sergiomb gravatar image

hum for install nVidia proprietary kernel is much more simple user rpmfusion .

http://rpmfusion.org/Configuration

depend in yours video card you may install

yum install akmod-nvidia xorg-x11-drv-nvidia kmod-nvidia

or for old cards

yum install akmod-nvidia-304xx xorg-x11-drv-nvidia-304xx kmod-nvidia-304xx
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-06 09:34:54 -0500

Seen: 1,612 times

Last updated: Jan 29 '14