Ask Your Question
3

DRM Flash Videos

asked 2014-01-09 22:27:51 -0500

Floyd gravatar image

updated 2014-02-27 01:13:32 -0500

davidva gravatar image

Flash problem again....

Someone asked pretty much similar question here, and the short story is that movies in Google Play and Amazon are DRM, which requires linux user to install a package called "hal". However Fedora has removed this package for a while, so I was wondering if anyone could come up with solution that let fedora user to play these movies too?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2014-01-11 14:20:30 -0500

davidva gravatar image

Hi, HAL is no longer centric to most modern Linux systems (now we have UDev, UDisks etc). But I maked a rpm with hal-flash bassed in cshorler and it resolve the problem about DRM in flash.

INSTALLATION

First Install flash plugin...

Next

From a terminal...

32bits

su
yum install http://sourceforge.net/projects/postinstaller/files/fedora/releases/20/i386/updates/hal-flash-0.2.0rc1-1.fc20.i686.rpm

64bits

su
yum install http://sourceforge.net/projects/postinstaller/files/fedora/releases/20/x86_64/updates/hal-flash-0.2.0rc1-1.fc20.x86_64.rpm
edit flag offensive delete link more

Comments

Alternative if you want updates about hal-flash install PostInstallerF ;)

davidva gravatar imagedavidva ( 2014-01-11 14:22:29 -0500 )edit

It did work, and thanks for making the package. However this requires me to switch to adobe flash player every time I want to watch a DRM vidoe because the other flash videos I usually watch doesn't really work with Adobe flash player.

Floyd gravatar imageFloyd ( 2014-01-11 18:31:18 -0500 )edit
1

Thank you Davidva, Your resolution to this issue hit the spot for me. My Videos play now. I am so glad I don't have to break out that other OS just to watch a video. Creating the package for it made installation easy. Being a newer user to Linux, I am still getting ramped up on the many commands and avenues to do things in Linux.

rsmith gravatar imagersmith ( 2014-04-20 16:23:01 -0500 )edit

+1. Enables watchespn in Firefox. (Doesn't help for Chrome since Chrome has it's own Flash player)

gshereme gravatar imagegshereme ( 2014-08-30 15:14:31 -0500 )edit
1

Fedora 23: sudo yum install https://sourceforge.net/projects/postinstaller/files/fedora/releases/23/x86_64/libhal1-flash-0.3.2-1.20151001gitc213405.fc23.x86_64.rpm

Fedora 24: sudo yum install https://sourceforge.net/projects/postinstaller/files/fedora/releases/24/x86_64/libhal1-flash-0.3.3-2.20160402git95cdd6e.fc24.x86_64.rpm

Or explore the releases for the version you have.

Voicu gravatar imageVoicu ( 2016-06-11 01:32:43 -0500 )edit
0

answered 2016-04-25 22:35:21 -0500

ernesto gravatar image

Complementing davidva's answer for a Fedora 23 installation:

DRM streaming sites like HBO Go and Amazon require you to have HAL (Hardware Abstraction Layer) installed. Unfortunately this component was removed long ago from fedora.

You can still install it own your own by running the following commands from the terminal:

First, install pm-utils, one of HAL's package dependencies not available in the fedora repositories.

For a 32-bit installation: wget ftp://195.220.108.108/linux/fedora/linux/updates/22/i386/p/pm-utils-1.4.1-31.fc22.i686.rpm

For a 64 bit installation:

wget ftp://195.220.108.108/linux/fedora/linux/updates/22/x86_64/p/pm-utils-1.4.1-31.fc22.x86_64.rpm

Second, enable a new software repository

sudo dnf copr enable robotmaxtron/Fakehal

Third, install HAL from the new repository

sudo dnf install fakehal

I've tested it with HBO Go. It runs but the video does not load in HD. Hopefully somebody can shed some light into how to get that to work.

Source for these instructions in spanish: link

edit flag offensive delete link more

Comments

The low quality thing is killing me. Hoping someone will post a solution that doesn't lower quality.

Brian P gravatar imageBrian P ( 2016-05-09 11:35:57 -0500 )edit
0

answered 2015-04-04 21:44:32 -0500

updated 2015-04-05 14:54:18 -0500

Just one problem. This doesn't work for me on F21 if SELinux is enabled. I tried following some instructions for previous Fedora versions for creating a policy module that works around it, but no luck (by the way I know nothing about SELinux). The only way that I can currently watch HBO Go is if I run "setenforce 0". But surely there is a better way...

edit flag offensive delete link more

Comments

This sounds like a different issue and should be dealt with in a question of its own. Please ask a new question about this, including the text of any SELinx alerts you're getting on this issue. (If you're not receiving alerts, you need to make sure that the SELinux Troubleshooter is running and that you're set to receive alerts.)

sideburns gravatar imagesideburns ( 2015-04-05 15:36:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-09 22:27:51 -0500

Seen: 14,604 times

Last updated: Apr 05 '15