Ask Your Question
1

Fedora 20: How can I log out in Gnome 3? [closed]

asked 2014-01-13 22:03:15 -0500

florian gravatar image

updated 2014-01-25 17:38:01 -0500

FranciscoD_ gravatar image

Current Gnome doesn't provide a log-off button anymore. How can I restore that button or how can I logoff from Gnome?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by FranciscoD_
close date 2014-01-25 22:25:41.712476

Comments

1

Dear Fedora developers. Please don't make people slam their heads on the table while using Fedora. It's nice you're taking care to create a good UI, but please do usability testing with Windows Users. I'm trying to introduce people to Linux, and they get repulsed by the un-intuitive UI. Even after having used Linux for many years, even I find the UI worse than Windows. Hope this would be taken positively to improve the usability of Fedora. Specifically about the logout button...why on earth couldn't it be kept next to the shutdown button?!

Nav gravatar imageNav ( 2014-01-25 10:11:31 -0500 )edit

Please file a bug upstream with Gnome. We use their software as is. If you're looking to rant, please write a post on your personal blog.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-01-25 22:24:05 -0500 )edit

Gnome is the default interface with Fedora. I am here because it seized up the system yet again, and after rebooting, I realized I can't find the "logout" button to try to figure out why (not that it matters, Gnome shell seems determined to lock out no matter what) and this feels just like one annoyance too many. So rant away, @Nav, you are not the only one feeling pissed off, and no amount of "take your problem to the Gnome devs" is going to fix it. Gnome is what a FC user seems first and last in their sessions, so it is not THEIR problem, but OUR problem.

Woland gravatar imageWoland ( 2014-10-29 17:04:33 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
4

answered 2014-01-13 22:22:35 -0500

hmaarrfk gravatar image

updated 2014-01-14 00:06:51 -0500

Is there not an option when you click on your name in the drop down menu of the top bar?

See screenshot below LogOut Button

Else, maybe try this:

https://extensions.gnome.org/extension/703/enable-log-out-button/

edit flag offensive delete link more

Comments

Fedora20 does not have the username in the drop down menu any more. That's why I was wondering. But the extension works fine. Thanks

florian gravatar imageflorian ( 2014-01-13 23:03:06 -0500 )edit

See updated answer.

hmaarrfk gravatar imagehmaarrfk ( 2014-01-14 00:06:07 -0500 )edit
3

I thought it's supposed to be switched on for F20's Gnome 3.10. There's a gsetting for it:

gsettings set org.gnome.shell always-show-log-out true

FranciscoD_ gravatar imageFranciscoD_ ( 2014-01-14 00:39:24 -0500 )edit

Florian, you might want to try to delete your gnome configuration if you upgraded from a previous distro. Porting old configuration doesn't always work well. Especially with gnome since they decided to use a binary based configuration system....

hmaarrfk gravatar imagehmaarrfk ( 2014-01-14 09:06:50 -0500 )edit

@hmaarrfk: I did not upgrade from previous version. I did a clean install of Fedora Heisenbug.

florian gravatar imageflorian ( 2014-01-14 10:29:43 -0500 )edit
2

answered 2014-01-14 23:02:57 -0500

robatino gravatar image

See https://ask.fedoraproject.org/question/30783/how-do-i-enable-the-logout-option-in-gnome-shell/. The answer is a one-line command. More generally, you can install dconf-editor, then go to org/gnome/shell, then check "always-show-log-out".

edit flag offensive delete link more
0

answered 2014-01-15 13:35:22 -0500

rafaelluik gravatar image

I've read somewhere that if you only have 1 user in your system GNOME won't show the username in the drop-down anymore since a recent version.

@robatino answer is complete!

edit flag offensive delete link more
0

answered 2014-01-13 23:09:23 -0500

Charles Wang gravatar image

Mr. hmaarrfk is right! Gnome 3.10 has also logoff and switch user menu in power menu.

edit flag offensive delete link more

Comments

OK, I copied /home/ from my previous system (Fedora 19) to the new system and I must have overridden the new Gnome 3.10 config with old stuff....

florian gravatar imageflorian ( 2014-01-14 07:55:13 -0500 )edit
-1

answered 2014-01-14 14:29:59 -0500

parasense gravatar image

You could always type something like 'loginctl kill-user $USER' in your terminal.

edit flag offensive delete link more

Comments

I wouldn't mind if you could explain what loginctl kill-user does.

florian gravatar imageflorian ( 2014-01-14 19:26:30 -0500 )edit

it would hostily vacate any user logins.

parasense gravatar imageparasense ( 2014-01-14 22:52:09 -0500 )edit

Question Tools

Stats

Asked: 2014-01-13 22:03:15 -0500

Seen: 32,849 times

Last updated: Jan 15 '14