Ask Your Question
3

Fedora 20: How to resolve dependency resolution errors with `librtmp`?

asked 2014-01-15 02:09:20 -0500

riclags gravatar image

updated 2014-09-30 11:12:16 -0500

mether gravatar image

Doing a yum update gives me the ff. dependency resolution messages:

--> Finished Dependency Resolution
Error: Package: mencoder-1.1-16.20131125svn.fc20.x86_64 (@rpmfusion-free)
       Requires: librtmp.so.0()(64bit)
       Removing: librtmp-2.4-0.3.20110811gitc58cfb3e.fc19.x86_64 (@rpmfusion-free)
           librtmp.so.0()(64bit)
       Updated By: librtmp-2.4-1.20131205.gitdc76f0a.fc20.x86_64 (rpmfusion-free-updates)
          ~librtmp.so.1()(64bit)
Error: Package: mplayer-1.1-16.20131125svn.fc20.x86_64 (@rpmfusion-free)
       Requires: librtmp.so.0()(64bit)
       Removing: librtmp-2.4-0.3.20110811gitc58cfb3e.fc19.x86_64 (@rpmfusion-free)
           librtmp.so.0()(64bit)
       Updated By: librtmp-2.4-1.20131205.gitdc76f0a.fc20.x86_64 (rpmfusion-free-updates)
          ~librtmp.so.1()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Being new to Fedora, I don't know how to go about this. Some questions:

  1. If I use --skip-broken flag, then yum will not update librtmp and leave it to version 2.4-0.3. I just have to wait for RPMFusion to get mencoder and mplayer updated with using librtmp-2.4-1... package and a yum update will resolve this error. Is this line of thinking correct?
  2. I have no idea what rpm -Va --nofiles --nodigest does...can someone care to explain?
edit retag flag offensive close merge delete

Comments

Yum gives you a bad advice (--skip-broken or using rpm directly, i think these error messages should be improved because they confuse users too often). As always in case of yum problems do first: yum clean all; yum repolist - are all repos enabled as expected? See for a similar problem here https://ask.fedoraproject.org/question/29534/a-problem-in-installing-spe-python-editor/

marcindulak gravatar imagemarcindulak ( 2014-01-15 02:21:52 -0500 )edit

I'm still getting the same error messages after doing yum clean all and yum repolist. AFAIK, I didn't disable any repos, and added only adobe-linux and the rpmfusion* repos. Looking closely at the error, it's trying to update from librtmp-2.4-0.3.20110811gitc58cfb3e.fc19.x86_64 to librtmp-2.4-1.20131205.gitdc76f0a.fc20.x86_64, so should I just wait for maintainers of mencoder and mplayer to fix this?

riclags gravatar imagericlags ( 2014-01-15 02:44:37 -0500 )edit

I see this is indeed inconsistency between the mplayer/mencoder from rpmfusion-free and librtmp from rpmfusion-free-updates - yum update librtmp triggers your error. Follow one of the answers below depending on your temperament - or simply wait with yum update a couple of days, applying only critical updates

marcindulak gravatar imagemarcindulak ( 2014-01-15 05:16:27 -0500 )edit

For "rpm -Va --nofiles --nodigest" - see man rpm, section "VERIFY OPTIONS" - the command "verifies" all packages (-a option combined with -V)

marcindulak gravatar imagemarcindulak ( 2014-01-15 05:23:35 -0500 )edit

I'm dealing with a similar issue with npm & nodejs; though, I do have librtmp already installed, seemingly from a 3rd-party source--since yum simply says Repo: installed. I suppose it's as simple as waiting it out, since newest doesn't always mean greatest.

ILMostro gravatar imageILMostro ( 2014-01-15 07:19:24 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
2

answered 2014-01-15 17:41:32 -0500

sergiomb gravatar image

Hi, rpmfusion also rebuild all packages that depends on librtmp , please try yum update again if if you still have this issue , please add to yum command --enablerepo=rpmfusion-free-updates-testing

edit flag offensive delete link more

Comments

1

I just tried yum update again and no more issues with librtmp. I didn't have to --enablerepo=rpmfusion-free-updates-testing when I did the update. Thanks everyone for the responses.

riclags gravatar imagericlags ( 2014-01-15 20:03:10 -0500 )edit
2

answered 2014-01-15 04:58:26 -0500

Glenn gravatar image

There is nothing to fix. Use --skip-broken and get the updates that you can get. For the others just wait a day or two. There is nothing critical here.

These types of errors are not uncommon for Fedora / Yum and are usually corrected in short order.

edit flag offensive delete link more
2

answered 2014-01-15 18:18:30 -0500

newk0001 gravatar image

I had the same problem yesterday (1-14-2014). Today when I got home from work I ran sudo yum update and everything was straightened out.

edit flag offensive delete link more
1

answered 2014-01-15 04:47:57 -0500

setcho gravatar image

FYI I'm a total noob to fedora so if someone has a more detailed answer and explanation you should probably listen to them. In order to fix this error I applied a similar rationale that I would use with Debian i.e. enable the testing repos.

So in yum enable rpmfusion-free-updates-testing and then select the newest version of mplayer which is 1.1-18 then install mplayer and librtmp at the same time.

This fixed it for me, remember to untick rpmfusion-free-updates-testing afterwards.

edit flag offensive delete link more
0

answered 2014-01-27 03:58:46 -0500

Please see this post over on fedoraforum.org .

I think it's an issue upstream with the SELinux-policy. The above-mentioned link explains how to fix these issues:

  setenforce 0
  yum clean expire-cache
  yum update selinux-policy\*
  setenforce 1

Alternatively, try disabling the SELinux altogether, and relabel your fs with # touch /.autorelabel

or, append selinux=0 to your kernel commandline and then do the updates.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-15 02:09:20 -0500

Seen: 21,639 times

Last updated: Jan 27 '14