English
Ask Your Question
1

How to install a bluetooth keyboard in Fedora 20 that works before login and for all users

asked 2014-01-18 03:26:21 +0000

Mark Richards gravatar image

I followed the instructions in this question: ask.fedoraproject.org/question/38464/how-to-install-a-bluetooth-keyboard-in-fedora-20/ and was able to pair my keyboard. However, this is totally useless since the keyboard doesn't pair until after the user logs in, and I need the keyboard in order to log in.

How can I make the keyboard pair, on boot, for all users?

edit retag flag offensive close merge delete

Comments

Also found this wiki https://wiki.archlinux.org/index.php/Bluetooth#Configuration_via_the_CLI about setting up bluetooth from cli.

ns47731 ( 2014-09-26 03:03:46 +0000 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-02-16 00:36:15 +0000

I'm new to Fedora and encountered the exact same problem. On Ubuntu, my keyboard always worked at log-in no probs, so I'm not sure why Fedora is being difficult about it. I consider this a bug, as keyboards, and indeed other bluetooth devices such as modems may well require to be available at log-in.

I got mine working at log-in system-wide following the Arch Linux wiki page: https://wiki.archlinux.org/index.php/Bluetooth#Configuration_via_the_CLI

(copy paste)

  • Start the bluetoothctl interactive command. There one can input help to get a list of available commands.
  • Turn the power to the controller on by entering power on. It is off by default.
  • Enter devices to get the MAC Address of the device with which to pair.
  • Enter device discovery mode with scan on command if device is not yet on the list.
  • Turn the agent on with agent on.
  • Enter pair MAC Address to do the pairing (tab completion works). If using a device without a PIN, one may need to manually trust the device before it can reconnect successfully. Enter 'trust MAC Address' to do so.
  • Finally, use connect MAC_address to establish a connection.

I then created a udev rules file as the wiki describes:

In order to have the device active after a reboot, a udev rule is needed: /etc/udev/rules.d/10-local.rules

# Set bluetooth power up
ACTION=="add", KERNEL=="hci0", RUN+="/usr/bin/hciconfig hci0 up"

Now, my keyboard works perfectly.

edit flag offensive delete link more

Comments

Thanks mate! The setup worked, I haven't checked yet if it comes back to live after reboot but if it fails I will figure out what to do ;)

runlevel0 ( 2014-09-07 12:18:51 +0000 )edit

Thanks mate! I tried the 'add-10-local.rules' on my Fedora 20 (upgraded from Fedora 19), it works perfectly!

ywanb ( 2014-09-27 16:04:21 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2014-01-18 03:26:21 +0000

Seen: 7,309 times

Last updated: Feb 16 '14