Ask Your Question
4

How do I make my system suspend when I close the laptop lid?

asked 2014-01-25 22:41:57 -0500

axldavis2012 gravatar image

updated 2015-03-03 05:46:28 -0500

FranciscoD_ gravatar image

Hello I have a Lenovo T43 and if I hold the Fn button and press the F4 button which is also the suspend or sleep button it will suspend and wake up properly but if i close the lid the laptop will not suspend also i fresh installed fedora 20 on it with gnome 3 on it ok so

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
6

answered 2014-01-26 01:35:01 -0500

TForsman gravatar image

To be able to change the way fedora acts when closing the lid on laptop, open the file:

sudo gedit /etc/systemd/logind.conf

Find: #HandleLidSwitch=suspend

Just remove the # and save the file.

And restart the service to make it work without reboot the system as root:

systemctl restart systemd-logind.service
edit flag offensive delete link more

Comments

Is there an option for "handle lid switch when on batter = suspend"?

alfC gravatar imagealfC ( 2014-09-01 21:26:23 -0500 )edit

didn't help at all. still locks up the system when the lid accidentally gets closed.

rpdayton gravatar imagerpdayton ( 2015-03-02 07:33:19 -0500 )edit

For some reason this works only as long until you restart your laptop. After restarting, closing the lid causes the laptop only to lock and not go to sleep mode.

...but if you restart systemd-logind after you have restarted your laptop it will work again!

Weird.

Orma Jollila gravatar imageOrma Jollila ( 2015-04-07 03:54:40 -0500 )edit
4

answered 2014-01-26 11:33:43 -0500

NickTux gravatar image

updated 2014-01-26 12:34:41 -0500

For the GNOME desktop , you can install gnome-tweak-tool and change the behavior from there.

sudo yum install gnome-tweak-tool

Open it and go to Power. There you will see the option "When Laptop Lid is Closed"

image description

Above doesn't work for now in Fedora 20 , due to a bug , report can be found here . The power options "when lid closed" are missing on gnome-tweak-tool. Although the default behavior is the 'suspend' when lid is closed.

For now, you can try the manual configuration of a file ( /etc/systemd/logind.conf ) as this described in @TForsman answer.

edit flag offensive delete link more

Comments

i already tried with gnome tweak but the Tforsman one works with the command thank you so verymuch

axldavis2012 gravatar imageaxldavis2012 ( 2014-01-27 14:34:10 -0500 )edit

Please convert/delete your answer and add it as a comment. The select the @TFosman 's answer as the correct one. Thanks.

NickTux gravatar imageNickTux ( 2014-01-28 03:59:54 -0500 )edit

I am quite disappointed that the last time the bug was commented on was in April

thaweatherman gravatar imagethaweatherman ( 2014-08-05 20:55:01 -0500 )edit

This no longer works. It is no longer handled by GNOME.

deadrat gravatar imagedeadrat ( 2015-03-06 11:28:00 -0500 )edit
-1

answered 2014-02-01 17:42:03 -0500

andyturner87 gravatar image

the power manager app does it too

edit flag offensive delete link more

Comments

Can you provide a more substantial answer please ? This seems like a comment. Give instructions for a newbie user and also a screen-shoot would be good.

NickTux gravatar imageNickTux ( 2014-02-01 18:13:52 -0500 )edit
-1

answered 2015-03-02 07:31:43 -0500

rpdayton gravatar image

yeah - this doesn't help at all. laptop still freezes when lid is closed.

edit flag offensive delete link more

Comments

that's a different issue, and not related to this question. Please ask another question.

FranciscoD_ gravatar imageFranciscoD_ ( 2015-03-03 05:48:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-25 22:41:57 -0500

Seen: 29,496 times

Last updated: Mar 03 '15