English
Ask Your Question
1

Remap windows/super key

asked 2014-02-17 08:27:40 +0000

MichalEF gravatar image

updated 2014-02-17 14:05:36 +0000

mether gravatar image

Hi,

I have just stared using Fedora 19 with Gnome. I used to use XUbuntu with XFCE. I really liked to use gnome-do. In short this helper works like this: when you hit windows/super key + space it opens small panel and you can type name of application you want to lunch.

But in Fedora 19 windows/super key is already binded - when I hit super key I got some kind of dash board. Now it is cause that super key + space combination does not work. And I have to hit super + space twice to lunch gnome-do.

I was looking for super key binding in settings but could not find action for bare super key. BTW all combinations of super key + <other key=""> defined in keyboard settings works just fine. I just do not get what should I change in my settings to have combination super + space work fine.</other>

Regards

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-02-18 14:48:58 +0000

Ahmad Samir gravatar image

You can do that by editing the "org.gnome.mutter overlay-key" key, as user in terminal:

gsettings set org.gnome.mutter overlay-key ""

or use dconf-editor and set the "org.gnome.mutter overlay-key" to an empty string.

edit flag offensive delete link more
0

answered 2014-02-18 19:32:08 +0000

hmaarrfk gravatar image

The windows key is being used as the new modifier for all Gnome Shell specific shortcuts.

Super+space is actually mapped to changing input languages. Check out the Keyboard settings in Settings.

An other very useful tool for customizing Gnome shell is "Gnome tweak tools". They have many options there that you might find useful.

I would also suggest upgrading to F20. Some of the gnome binding have changed (I think...). I believe if you change the language switch binding, that gnome-do "should" work. I consider gnome-shell pretty fast moving. Every release fixes a TON of stuff that were just wrong with the old one.

FINALLY, correct me if i'm wrong, but gnome-do seems to be orphaned and recently revived.

Fedora has

Name        : gnome-do
Arch        : x86_64
Version     : 0.9

in the repositories which was released in 2012. That was a long time ago in terms of gnome-shell's maturity. You might want to consider using gnome-shell's integrated "do anything" with the super key while gnome-do's team works on the project again.

edit flag offensive delete link more

Comments

Maybe all he needed to do was unassign the Super+Space shortcut in the gnome shortcut settings?

Ahmad Samir ( 2014-02-18 20:13:39 +0000 )edit

Yea I think so too.

hmaarrfk ( 2014-02-18 21:12:26 +0000 )edit

Well I have checked and in my setup Super+space is not mapped to change input languages in Settings->Keyboard. Upgrading is out of my control as I am not responsible of that. Finally, I really got used to gnome-do and I was using it with succes on Ubuntu and Fedora up to 19 version. In F19 there is no problem with gnome-do, rather with gnome-shell key bindings.

MichalEF ( 2014-02-19 10:43:04 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2014-02-17 08:27:40 +0000

Seen: 4,431 times

Last updated: Feb 18 '14