Ask Your Question
6

UEFI Dual Boot : Windows 8.1 and Fedora 20

asked 2014-02-21 08:47:32 -0500

thehunt33r gravatar image

Hi !

So I guess this question is pretty common, but I haven't found any answer yet. I have my dual boot installed on my laptop. Windows 8.1 in a drive, Fedora 20 in another. In the UEFI, boot is set to Fedora, which will take me to Grub. If, from Grub, I try to start Windows Boot Manager I have an error : "\EFI\Microsoft\Boot\bootmgfw.efi is missing". So for the last week, I've used my F7 (UEFI Boot menu) to boot Windows when I want it, but it's messy. Is there a way to "repair" Grub ? Or maybe a different bootloader ?

edit retag flag offensive close merge delete

Comments

It looks like you have two EFI partitions, to confirm post the output of this run as root:

parted -l

Ahmad Samir gravatar imageAhmad Samir ( 2014-02-21 10:58:24 -0500 )edit

Here is the output : http://pastebin.com/6VsvcjB6

thehunt33r gravatar imagethehunt33r ( 2014-02-21 11:02:47 -0500 )edit

5 Answers

Sort by » oldest newest most voted
3

answered 2014-02-22 00:10:31 -0500

Ahmad Samir gravatar image

updated 2014-02-22 00:14:45 -0500

Looking at the output of parted -l, you have two EFI partitions, one on /dev/sda (Windows) and one on /dev/sdc (Fedora). The error you get is because GRUB is looking for bootmgfw.efi on /dev/sdc1 (it's actually on /dev/sda2, the windows EFI partition)

A couple of options:

menuentry 'Windows Boot Manager' {
           set root='hd0,gpt2'
           chainloader /EFI/Microsoft/Boot/bootmgfw.efi
           boot
}

basically you add a set root line which tells GRUB to look for /EFI/Microsoft/Boot/bootmgfw.efi on /dev/sda2. (Note that I've never tried this method before but it should work).

  • Alternatively you can do a clean Fedora install and make sure the installer sets the mount point of the Windows (original?) EFI partition as /boot/efi, that would be /dev/sda2. (And delete the second EFI partition /dev/sdc1 afterwards).

EDIT: the device nodes (sda, sdb... etc) above are based on the output of parted -l that you posted, if you remove e.g. the ATA SanDisk SDSSDH21 device, the enumeration will change, so make sure you don't delete the wrong partition.

Also, IMHO using a single EFI partition is the cleanest way since you don't have to worry about future installs ... etc.

edit flag offensive delete link more

Comments

Thanks ! I modified /boot/efi/EFI/fedora/grub.cfg and it works great.

thehunt33r gravatar imagethehunt33r ( 2014-02-22 04:41:53 -0500 )edit

Please see @paulb's answer in this question, his method is more robust.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-09 07:43:10 -0500 )edit

Modifying grub.cfg was a great quick fix, thanks so much!

zchilders gravatar imagezchilders ( 2014-05-09 15:34:30 -0500 )edit

There is already a bug filled about this issue (I don't know the link right now). Hopefully will be fixed for Fedora 21.

hedayat gravatar imagehedayat ( 2014-06-14 03:02:56 -0500 )edit
0

answered 2014-03-29 05:10:15 -0500

Hey how do I edit /boot/efi/EFI/fedora/grub.cfg for booting windows 8.1 from grub Here is the result of parted http://pastebin.com/dRCZ7krl

edit flag offensive delete link more

Comments

This looks like a different issue than thehunt33r, since from the output you posted it's apparent you only have one HDD and one EFI system partition.

If you don't have a windows entry at all in GRUB, then you just need to execute this command as root:

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

it should detect the windows installation and add an entry for it. If that doesn't work please start a new question in this forum.

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-29 10:19:22 -0500 )edit
0

answered 2014-02-21 10:06:33 -0500

deusdara gravatar image

Hi

Please follow those steps on thread below

Install Ubuntu or Fedora In Dual Boot With Windows 8.1 UEFI

http://amidstsky.com/tech/install-ubuntu-or-fedora-in-dual-boot-with-windows-8-1-uefi/

edit flag offensive delete link more

Comments

Hi ! I think this is not my problem, as I can successfully boot Fedora without any problem (my laptop is pretty free around its UEFI) Fedora is already installed. I have no problem accessing it, but I want to be able to boot Windows from Grub.

Sorry if it was what you meant, but I didn't found anything valuable on your link.

Thanks

thehunt33r gravatar imagethehunt33r ( 2014-02-21 10:53:18 -0500 )edit
0

answered 2014-02-21 19:46:21 -0500

Sempay gravatar image

Boot Fedora , open terminal and make as root grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg Then reboot.

edit flag offensive delete link more
0

answered 2015-04-19 00:01:39 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hello,

Ma with great satisfaction'm sticking to Linux undo, and I see a responsible and active community.

Well my problem is that after installing Fedora 21 following a tutrial on youtube showed the notebook boot the boot manager option appearing only Fedora 21 and Fedora rescue, how to display the boot manager to start the windows?

I am a beginner in Linux User

My notebook came installed W8.1.   thank you

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-02-21 08:47:32 -0500

Seen: 36,642 times

Last updated: Mar 29 '14