Ask Your Question
0

After adding hard drives to the system Fedora won't boot.

asked 2014-03-02 06:16:11 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hello there Fedora community.

Two days ago I installed Fedora 20 in my PC. There are in my machine: 1 DVD drive, 1 SSD, 2 HDDs, and 1 external USB hard drive.

The plan was to use one of the hard disks to install Fedora and to prevent any unwanted changes to the other drives during installation I simply disconnected the sata cables from the other two disks.

The install process went fine, but now if I connect the other drives and try to boot the system I get some error message and the system refuses to boot. Hot plugging the drives after the system has booted works fine though.

I suppose the loader gets confused as to what device should be read for booting, as the order of the drives change if I plug the other drives before booting, meaning with other drives plugged the HD with Fedora ceases to be /dev/sda to be something else.

How can I solve this?

edit retag flag offensive close merge delete

Comments

I have got different OS's (Windows 7, Fedora 20, XP, DVD, bluray) installed in different drives and works without any issues. Did u try updating your BIOS software?

anishjp gravatar imageanishjp ( 2014-03-02 06:43:45 -0500 )edit

How was Fedora installed? Were the other drives plugged during the install process?

I figure this problem has to do with the fact the install process was not aware of the other drives (since they were not plugged), and re-adding them makes the os loader confused. But I dont know what to do from here.

It doesnt feel like something a BIOS update is related to this issue. I can go to the EFI config screen and select which hard drive to boot from. If the other drives are plugged Fedora will not boot.

Linux at last gravatar imageLinux at last ( 2014-03-02 07:13:34 -0500 )edit

@linux_at_last: I always install fedora after disconnecting all the other drives. Once the installaton is complete and setup complete, I shut it down and connect back all the other drives. Fedora harddrive is the first to boot in the BIOS menu. May be yours is an isolated problem. Anyway glad u came right!

anishjp gravatar imageanishjp ( 2014-03-02 13:53:06 -0500 )edit

@anishjp: My guess would be this: the problem ocurred because the HD in which fedora was installed was not in the first sata port, another HD was at that port. But then, after removing the other HDs the systems sees it as "hard drive 1". Finally, after putting the other drives back some other HD becomes "hard drive 1" but now the boot loader won´t find any linux there since there´s no Fedora in the new HD. Seems to make some sense.

Thanks for coming by.

Linux at last gravatar imageLinux at last ( 2014-03-02 15:02:44 -0500 )edit

Your computer bios indicates the physical address (boot sequence) of hard drives, Example, Flash, DVD, harddisk x, harddisk y, etc.

When you added the hard drive, you probably swapped locations with the cabling, (If you use sata), or if your machine is older, the new drive displaced the hardware address of the original.

All bios's allow you to a) hold a key down (F2, F8, F10 or other) and your computer will present you with a list of drives from which to boot. You can also get into the bios setup and tell the system which drives it is that you want it as first and second.

lsatenstein gravatar imagelsatenstein ( 2014-03-08 03:51:34 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-03-02 07:28:57 -0500

Alexunder gravatar image

updated 2014-03-02 08:58:10 -0500

Try to boot with a live CD(and the hard drives plugged in) to update the Grub program.

http://fedoraproject.org/wiki/GRUB_2

edit flag offensive delete link more

Comments

Hey, that solved the problem @Alexunder.

I simply unplugged the drives, booted Fedora, repluged the drives and ran the following command:grub2-mkconfig -o /boot/grub2/grub.cfg

The boot grub.cfg file was updated and now Fedora boots normally.

Linux at last gravatar imageLinux at last ( 2014-03-02 11:00:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-03-02 06:16:11 -0500

Seen: 3,359 times

Last updated: Mar 02 '14