Ask Your Question
0

How to make vnc server work on fedora 19

asked 2014-03-06 05:29:13 -0600

dubi gravatar image

updated 2014-03-06 11:16:46 -0600

cobra gravatar image

I have fedora 19

Installed tigervnc package

ran : /usr/bin/vncserver as root and supplied password (is the vncserver from the tigervnc ?)

4.log and 4.pid were generated under .vnc as well as xstartup

GNOME is installed in the machine

tried to access the machine (vnc server) from a client on windows by <vnc machine="" server="">:4 and got no prompt for password .</vnc>

This works fine on an older fedora14 machine

any help ?

I see no vncconfig installed on the fedora 19 ( but also not refernce to it from the xstartup file as was with fedora 14)

Here is the .vnc/xstartup file :

#!/bin/sh

unset SESSION_MANAGER

unset DBUS_SESSION_BUS_ADDRESS

OS=`uname -s`

if [ $OS = 'Linux' ]; then

  case "$WINDOWMANAGER" in

    *gnome*)

      if [ -e /etc/SuSE-release ]; then

        PATH=$PATH:/opt/gnome/bin

        export PATH

      fi

      ;;

  esac

fi

if [ -x /etc/X11/xinit/xinitrc ]; then

  exec /etc/X11/xinit/xinitrc

fi

if [ -f /etc/X11/xinit/xinitrc ]; then

  exec sh /etc/X11/xinit/xinitrc

fi

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources

xsetroot -solid grey

xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &

here is

edit retag flag offensive close merge delete

Comments

Did you set the firewall to allow connection to vnc port 5900?

aeperezt gravatar imageaeperezt ( 2014-03-06 14:40:30 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-06 15:14:47 -0600

Marc lml gravatar image
edit flag offensive delete link more

Comments

thx. problem solved !

dubi gravatar imagedubi ( 2014-03-07 01:16:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-06 05:29:13 -0600

Seen: 232 times

Last updated: Mar 06 '14