English
Ask Your Question
0

Touchpad no longer respecting settings, doesn't scroll

asked 2014-03-10 08:47:39 +0000

kazade gravatar image

updated 2014-03-11 08:52:18 +0000

Im running Fedora 20 on a Dell XPS 13 (Sputnik) until a couple of weeks ago everything was working fine, but suddenly (either due to an update, or something I've done) the touchpad stopped scrolling (both edge scrolling, and two-finger scrolling).

The touchpad also always behaves with "tap-to-click" even if I disable it in the GNOME settings. Nothing in that panel seems to have any affect.

The relevant part of Xorg.0.log is:

[    12.960] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event4)
[    12.960] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    12.960] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    12.960] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    12.960] (II) LoadModule: "synaptics"
[    12.960] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    12.961] (II) Module synaptics: vendor="X.Org Foundation"
[    12.961]    compiled for 1.14.4, module version = 1.7.1
[    12.961]    Module class: X.Org XInput Driver
[    12.961]    ABI class: X.Org XInput driver, version 19.2
[    12.961] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    12.961] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    12.961] (**) Option "Device" "/dev/input/event4"
[    12.984] (II) synaptics: SynPS/2 Synaptics TouchPad: found clickpad property
[    12.984] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5676 (res 45)
[    12.984] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4722 (res 60)
[    12.984] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    12.984] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    12.984] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left double triple
[    12.984] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    12.984] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
[    12.984] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    12.984] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    12.994] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input5/event4"
[    12.994] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 13)
[    12.994] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    12.994] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    12.994] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.037
[    12.994] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    12.994] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    12.994] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    12.994] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    12.994] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    12.994] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    12.995] (II) No input driver specified, ignoring this device.
[    12.995] (II) This device may have been added with another device file.

Can anyone help me fix the problem? Google isn't turning up anything helpful :(

UPDATE: Another clue! When the laptop resumes ... (more)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-03-10 23:57:02 +0000

sergiomb gravatar image

please see if synclient is detecting yours touchpad

synclient -l | grep -i scroll 

synclient -l | grep -i tap

you may adjust

synclient VertTwoFingerScroll=1
synclient HorizTwoFingerScroll=1
synclient VertEdgeScroll=1
synclient HorizEdgeScroll=1
synclient TapButton1=1
synclient TapButton2=1
synclient TapButton3=1

reading last clue "synclient can't find the touchpad" that is a kernel problem when resume from suspend , try a previous kernel that works and report a bug in last kernel in redhat.bugzilla.com please .

https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=20&component=kernel

edit flag offensive delete link more

Comments

Bug reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1074910

I've updated the OP with the output of synclient

kazade ( 2014-03-11 08:53:09 +0000 )edit
0

answered 2014-03-10 13:20:58 +0000

split141 gravatar image

updated 2014-03-10 13:23:49 +0000

Last week I installed Fedora 20. Touchpad was working fine. I went into system settings -> input devices -> touchpad and increased touchpad sensitivity and did few other things. After I applied those changes my touchpad stopped working. The buttons on the touchpad worked but I couldn't use the touchpad to move around. I struggled with it for a long time, re-installing packages, removing and installing packages etc. The touchpad worked till the system brought up the desktop. After creating a new user and changing the touchpad sensitivity I figured it out. If the sensitivity of the touchpad is set to higher than 30 to 40%, it stops working. Also, once I set the sensitivity higher than 40%, I could not disable touchpad and make those changes stick; if I disable the touchpad and went back in, I saw that touchpad was re-enabled. Thought I share these findings.

Bottom line, if you touchpad sensitivity is set higher than 40%, lower it to 30% or lower and see if that solves the problem.

edit flag offensive delete link more

Comments

No such luck :(

Even weirder, when I resume from suspend, the whole touchpad panel disappears from GNOME and synclient can't find the device at all! It still operates the same though.. like a mouse...

kazade ( 2014-03-10 18:14:13 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-03-10 08:47:39 +0000

Seen: 2,445 times

Last updated: Mar 11 '14