Ask Your Question
0

Install Fedora on UEFI Laptop w/o biosboot partition

asked 2014-03-19 16:36:58 -0500

firefexx gravatar image

Hi, I'm trying to install Fedora on a new ThinkPad T440s with an UEFI.

I formatted the SSD with a GPT and booted a netinstall USB-Stick. After partitioning, it gives an error and says

"Your BIOS-based system needs a special partition to boot from a GPT disk label. To continue, please create a 1MB 'biosboot' type partition."

My question is: Why??

What is the "BIOS-based system"? The laptop? I doubt that, since it has an UEFI. Fedora? So I can't use it w/o the biosboot partition?

Could someone clarify this?

edit retag flag offensive close merge delete

Comments

2

My guess is that the installer wasn't booted in UEFI mode and so it's defaulting to a BIOS-based installation.

In your UEFI firmware settings, make sure CSM/Legacy boot is disabled, to be sure the installer is booting in UEFI mode.

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-20 09:34:29 -0500 )edit

Yes, you are right. Unfortunately the live USB stick is not bootable in UEFI only mode. Does someone know why? Bug with liveusb-creator or something else? However, booting a netinstall CD worked and it doesn't complain about biosboot partition. Instead it complains about a missing EFI system partition -.- Is this always necessarry to have this? Doesn't UEFI/GPT work w/o either biosboot or EFI system partition?

firefexx gravatar imagefirefexx ( 2014-03-20 15:27:03 -0500 )edit

I don't know why the usb stick doesn't boot in UEFI mode, it should work AFAIK... what happens exactly when you try to boot it in UEFI mode?

For UEFI systems an EFI system partition (ESP) is needed; the installer automatically creates it if you select automatic partitioning. However if you use custom partitioning you need to create it manually; create a 200MB (this is the default size the installer uses in guided-mode) partition mounted at /boot/efi and make sure the "File System" is set to "EFI system partition".

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-21 09:16:46 -0500 )edit

Ok, thank you for clarifying. When I select the USB stick as the boot device during startup, it immediately returns to the device delection screen, again and again.

firefexx gravatar imagefirefexx ( 2014-03-22 04:25:36 -0500 )edit

Did you verify the downloaded ISO?

I guess the ISO is most likely OK since it worked when you burned it to a CD and used it to boot. It could be something with the USB, I'd try putting the ISO on the stick again. You could also try some other method e.g. using dd (of course be extra careful when using this method).

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-22 06:53:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-31 11:27:45 -0500

Ervin-Reloaded gravatar image

Just disable UEFI in the settings. No big deal if you disable it.

edit flag offensive delete link more

Comments

No need to do that. Just write the the iso using dd and you will end up with an UEFI capable usb pendrive. Install, and be happy. Format SDD/HDD during installation. No need to pre-format any partition layout. Just never change from (U)EFI to BIOS or vice-versa once any OS is installed.

florian gravatar imageflorian ( 2016-02-01 13:15:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-19 16:36:58 -0500

Seen: 2,831 times

Last updated: Jan 31 '16