Ask Your Question
6

Playing mp4v, avi, mkv files on Fedora 20 [closed]

asked 2014-03-31 12:03:57 -0500

mohanprakash gravatar image

updated 2017-01-13 15:06:41 -0500

mattdm gravatar image

What is the easiest way to play mp4v, avi, mkv files on Fedora?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by davidva
close date 2018-04-07 21:02:56.082210

Comments

1

Also PostInstallerF installs the codecs you need.

davidva gravatar imagedavidva ( 2015-02-09 21:03:19 -0500 )edit

You may consider installing xine if you are using KDE. Check this post for more information.

powergame gravatar imagepowergame ( 2016-08-29 08:03:28 -0500 )edit

8 Answers

Sort by ยป oldest newest most voted
4

answered 2014-03-31 14:41:25 -0500

sergiomb gravatar image

updated 2014-10-26 17:54:32 -0500

Please see this question :

https://ask.fedoraproject.org/en/question/27881/help-i-cannot-play-a-dvd-in-videos-or-vlc-player-in-fedora-18/

I use smplayer from rpmfusion

you miss the part ? NOW you will install all codecs, yeah:

yum -y install gstreamer-plugins-bad gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-ugly gstreamer-ffmpeg


yum -y install gstreamer1-libav gstreamer1-plugins-bad-free-extras gstreamer1-plugins-bad-freeworld gstreamer1-plugins-base-tools gstreamer1-plugins-good-extras gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-good gstreamer1-plugins-base gstreamer1
edit flag offensive delete link more

Comments

1

the instructions in that link are not working for me.
I am getting No suitable decoder module: VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this. error for mkv files
No suitable decoder module: VLC does not support the audio or video format "mp4v". Unfortunately there is no way for you to fix this. for avi files
No suitable decoder module: VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this. for mp4 files

mohanprakash gravatar imagemohanprakash ( 2014-04-01 07:40:48 -0500 )edit
1

A system update is perhaps recommended before installing the codecs. My new installation on the same machine with system updates and then the directions given by you work perfectly. Previously I didn't do a system update. Thanks for your help.

mohanprakash gravatar imagemohanprakash ( 2014-04-03 06:44:21 -0500 )edit
1

h.264 seems to be in gstreamer1-libav

Aleksandar Kostadinov gravatar imageAleksandar Kostadinov ( 2014-07-02 07:05:13 -0500 )edit
1

@sergiomb There is a rouge "updates" in your second command.

somethingSomething gravatar imagesomethingSomething ( 2014-10-26 15:31:12 -0500 )edit

is is fixed ! I guess

sergiomb gravatar imagesergiomb ( 2016-08-29 13:08:01 -0500 )edit
3

answered 2014-03-31 13:46:48 -0500

SDas gravatar image

First you need to install rpmfusion. connect to the internet then search rpmfusion followed by your os name and version, then install rpmfusion from the directed steps in the website, there are two types of rpmfusion free and non free chose which you want to install. You can also follow the link to proceed. http://rpmfusion.org/ After install rpmfusion double click in your mkv or avi file, the video will not play but starts to find necessary codecs needed, after the codecs found download and install them and wait until the process completes. It is better to restart your machine after installation complete. It works on my machine check if it also works on your machine. If every thing goes right you can play video files.

edit flag offensive delete link more

Comments

1

this does not work. All codecs are installed but still I cannot play video formats such as avi, mp4 and mkv. vlc and other players can play these files on Fedora 20 on my desktop but on Acer aspire 5740 they do not work

mohanprakash gravatar imagemohanprakash ( 2014-04-01 08:07:42 -0500 )edit
1

you installed rpmfusion repo ? which version of fedora you are using 32bit / 64 bit.

SDas gravatar imageSDas ( 2014-04-02 01:08:37 -0500 )edit
1

Fedora 20, 64 bit

mohanprakash gravatar imagemohanprakash ( 2014-04-02 04:28:23 -0500 )edit
3

answered 2015-02-09 17:53:58 -0500

Obuntu Cracks gravatar image

[root@localhost apotnis]# yum install gstreamer-plugins-good gstreamer-plugins-bad gstreamer-plugins-ugly

edit flag offensive delete link more
2

answered 2015-09-19 15:28:00 -0500

jesusKDE gravatar image

thank man.

edit flag offensive delete link more

Comments

??? a old question??

davidva gravatar imagedavidva ( 2015-09-20 03:49:16 -0500 )edit
2

answered 2014-03-31 13:06:53 -0500

Marc lml gravatar image

The easiest way is to install codecs with Fedy (this was Fedorautils).

Install Fedy and then install the codecs.

su -c "curl http://satya164.github.io/fedy/fedy-installer -o fedy-installer && chmod +x fedy-installer && ./fedy-installer"

fedy --exec media_codecs

With fedy --exec list you can see all available commands.

Instead of using the command line, you can also use the GUI for Fedy.

edit flag offensive delete link more

Comments

fedy installs the codecs but the codecs do not work on acer aspire 5740

mohanprakash gravatar imagemohanprakash ( 2014-04-01 08:10:03 -0500 )edit

I use Gnome Mplayer. From your comment I see that you use VLC. Please try to install lame-libs (yum install lame-libs).

Marc lml gravatar imageMarc lml ( 2014-04-01 14:42:21 -0500 )edit

I use Fedora 20 and the default video viewer Totem and this solution is the only I could find to finally install all the codecs properly.Thanks!

yansan gravatar imageyansan ( 2014-06-07 01:28:36 -0500 )edit

very smooth! (fedora21_x64)

beingdevious gravatar imagebeingdevious ( 2014-12-24 09:53:30 -0500 )edit
1

answered 2014-04-03 06:41:33 -0500

mohanprakash gravatar image

There was a problem in the installation it seems. The system wouldn't boot. So I had to install the OS again. Now things are alright. avi, mp4 and mkv files are playing on Fedora's default video player. The following steps are recommended:
1. Install Fedora 20
2. Immediately after installing it would be best to first update the system using:

yum update

3. Install the codecs as per the instructions given in the above answers
Now the files should play
Thank you everybody for the help that you have extended

edit flag offensive delete link more
0

answered 2015-02-09 21:07:42 -0500

DJ007 gravatar image
yum install vlc

yum install xnoise
edit flag offensive delete link more

Comments

xnoise will be removed from Fedora because it is Orphaned

sergiomb gravatar imagesergiomb ( 2015-02-10 12:16:37 -0500 )edit
0

answered 2018-04-07 15:37:06 -0500

winq gravatar image

I tried the Terminal command to install the codecs and after the download was complete, I got this response

warning: /var/cache/dnf/rpmfusion-nonfree-b64e398859e20754/packages/gstreamer-plugins-bad-nonfree-0.10.23-5.fc27.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID b9c13282: NOKEY  Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-27 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-27]  The downloaded packages were saved in cache until the next successful transaction. You can remove cached packages by executing 'dnf clean packages'.

Anybody can help?

edit flag offensive delete link more

Comments

you should have /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-27 from rpmfusion-nonfree-release , maybe you just had installed free repo

sergiomb gravatar imagesergiomb ( 2018-04-08 21:21:00 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-31 12:03:57 -0500

Seen: 117,785 times

Last updated: Apr 07 '18