Ask Your Question
1

Fedora hangs right after starting gdm [closed]

asked 2014-04-13 21:21:09 -0500

abadrinath gravatar image

updated 2014-04-15 20:18:02 -0500

hello,

my machine worked fine yesterday. I didn't do any updates. I just looked at them (no internet). I have the text screen with the OKs and stuff with a cursor. nothing else.when I switch to tty2 and do service gdm status. there is a xorg colors problem.

help!!!!!!

EDIT: I cannot boot the system at all. How can I do those things?

EDIT2: I reinstalled this time with kde. No problems!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by abadrinath
close date 2014-07-21 05:34:48.725608

Comments

I have it on the lowest brightness. is that a problem??

abadrinath gravatar imageabadrinath ( 2014-04-13 21:22:43 -0500 )edit

Install the updates and reboot your system. Does this happen each time or only sometimes? Please edit your question and provide the requested information.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-04-14 01:43:25 -0500 )edit

Is this now resolved, or do you need further help?

cobra gravatar imagecobra ( 2014-04-16 03:21:34 -0500 )edit

Yep, I just reinstalled. Thanks for the help.

abadrinath gravatar imageabadrinath ( 2014-04-20 22:18:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-06-27 19:19:17 -0500

abadrinath gravatar image

Ah, the problem was that I disabled rpcbind.service, but not rpcbind.socket, resulting in some sort of hanging. If I had turned off the socket, that same problem would've been solved.

PS: I have tested this on my current KDE install, and it results in the same thing.

edit flag offensive delete link more

Comments

rpcbind.service as I read, is NFS related and it is not installed/enabled by default on Fedora 20. I don't have such service (I don't use one). Just a clarification, for future users with a default installation and similar problem. Don't search for rpcbind.service to enable, because they will not find one.

NickTux gravatar imageNickTux ( 2014-06-28 02:36:47 -0500 )edit

@NikTh - What do you mean?

abadrinath gravatar imageabadrinath ( 2014-06-30 22:35:01 -0500 )edit

rpcbind.service handles NFSv4 port mapping for NFS servers. You don't have to do anything with it, even if you use NFS; enabling nfs.service will bring it in automatically.

randomuser gravatar imagerandomuser ( 2014-07-01 00:19:52 -0500 )edit
1

I mean that, a user with a "hang" problem, might search for this service, when this service is not a default Fedora service (installed by default - when you install Fedora from Live USB...etc) and he/she will not find anything related. At this case, they don't need to think they have done something wrong, because rpcbind is an extra service that you have installed for NFS handling.

NickTux gravatar imageNickTux ( 2014-07-01 02:48:46 -0500 )edit

Isn't rpcbind enabled by default? On my F20 install, it was enabled.

abadrinath gravatar imageabadrinath ( 2014-07-01 06:07:13 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-13 21:21:09 -0500

Seen: 695 times

Last updated: Jun 27 '14