Ask Your Question
0

Yum update error

asked 2014-04-15 13:55:09 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

When i try to update my fedora 19 using yum ,, i have this problem :

Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for lcms2 which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of lcms2 of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude lcms2.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of lcms2 installed, but
        yum can only see an upgrade for one of those architectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of lcms2 installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

   Protected multilib versions: lcms2-2.5-1.fc19.i686 != lcms2-2.4-6.fc19.x86_64

Error: Protected multilib versions: freetype-2.4.11-7.fc19.i686 != freetype-2.4.11-6.fc19.x86_64 Error: Protected multilib versions: ghostscript-9.10-5.fc19.x86_64 != ghostscript-9.07-3.fc19.i686 Error: Protected multilib versions: keyutils-libs-1.5.8-1.fc19.i686 != keyutils-libs-1.5.5-4.fc19.x86_64 Error: Protected multilib versions: libtiff-4.0.3-9.fc19.i686 != libtiff-4.0.3-6.fc19.x86_64 Error: Protected multilib versions: 1:dbus-libs-1.6.12-2.fc19.i686 != 1:dbus-libs-1.6.8-5.fc19.x86_64 Error: Protected multilib versions: 1:cups-libs-1.6.4-2.fc19.i686 != 1:cups-libs-1.6.2-9.fc19.x86_64

Can any one help me

edit retag flag offensive close merge delete

Comments

Could you post the full output of yum to http://fpaste.org?

FWIW, both lcms2-2.5-1.fc19.i686 and lcms2-2.5.-1.fc19.x86_64 are available in the repos, so the error you got doesn't make sense...

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-16 03:46:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-15 14:26:50 -0500

mmellon1 gravatar image

It's telling you that you have the same packages of different architectures installed, however the versions are different. Look at the version numbers on each package, for example:

lcms2-2.5-1.fc19.i686 != lcms2-2.4-6.fc19.x86_64

The '!=' signifies that the packages do not equal one another, and if you look closely, you can see that is because the versions are mismatched. The numbers following the packages name (lcms2 is the package name) do not match up. It appears your 32-bit libraries are updated whereas your 64-bit libraries are not. For each package that comes up in the error you posted, try the following command:

$ sudo yum update [package-name] [package-name]

So on and so forth. Since you're running a 64-bit OS, yum will automatically update the out-of-date 64-bit libraries to (HOPEFULLY) match their 32-bit counterparts. Once that is done, retry:

$ sudo yum update

Hope this helps!

~Mark

edit flag offensive delete link more

Comments

I am new and i dont know so much on fedora so can you please help me a little bit more

Suhaib Alziq gravatar imageSuhaib Alziq ( 2014-04-15 14:35:25 -0500 )edit

Each line that says "Error: Protected multilib versions:" means that your 32-bit and 64-bit versions of the packages do not match up. So what you must do is manually type in $ sudo yum update followed by each package name listed in the error that you copied into your original post. For example, copy the following into your terminal and press enter: sudo yum update lcms2 freetype ghostscript keyutils-libs libtiff dbus-libs cups-libs. Once that is done, then type sudo yum update and hit enter.

mmellon1 gravatar imagemmellon1 ( 2014-04-15 14:44:07 -0500 )edit

Thank you ,, i tried what you told me but still the same problem so i tried to erase each package alone using

Yum erase [package-name]

Anyway thank you for your help :)

Suhaib Alziq gravatar imageSuhaib Alziq ( 2014-04-16 07:42:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-15 13:55:09 -0500

Seen: 892 times

Last updated: Apr 15 '14