Ask Your Question
0

wifi not working after upgrade kernel to 3.13.

asked 2014-04-23 03:01:35 -0500

Anand J gravatar image

updated 2014-04-23 03:21:54 -0500

cobra gravatar image

Hi,

After yum update and upgrading my kernel. My wifi is not working any more. After trying to install kmod-wl from rpmfusion-nonfree for my kernel I get transaction check error's and kmod-wl is not getting installed. Is there a solution or do i really have to downgrade my kernel?

output

[root@WFLXAJU01 ]# yum install kmod-wl
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package kmod-wl.x86_64 0:6.30.223.141-5.fc20 will be installed
--> Processing Dependency: kmod-wl-3.11.10-301.fc20.x86_64 >= 6.30.223.141-5.fc20 for package: kmod-wl-6.30.223.141-5.fc20.x86_64
--> Running transaction check
---> Package kmod-wl-3.11.10-301.fc20.x86_64.x86_64 0:6.30.223.141-5.fc20 will be installed
--> Processing Dependency: kernel-uname-r = 3.11.10-301.fc20.x86_64 for package: kmod-wl-3.11.10-301.fc20.x86_64-6.30.223.141-5.fc20.x86_64
--> Processing Dependency: wl-kmod-common >= 6.30.223.141 for package: kmod-wl-3.11.10-301.fc20.x86_64-6.30.223.141-5.fc20.x86_64
--> Running transaction check
---> Package broadcom-wl.noarch 0:6.30.223.141-2.fc20 will be installed
---> Package kernel.x86_64 0:3.11.10-301.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch   Version             Repository         Size
================================================================================
Installing:
 kernel                      x86_64 3.11.10-301.fc20    fedora             30 M
 kmod-wl                     x86_64 6.30.223.141-5.fc20 rpmfusion-nonfree  12 k
Installing for dependencies:
 broadcom-wl                 noarch 6.30.223.141-2.fc20 rpmfusion-nonfree  19 k
 kmod-wl-3.11.10-301.fc20.x86_64
                             x86_64 6.30.223.141-5.fc20 rpmfusion-nonfree 1.1 M

Transaction Summary
================================================================================
Install  2 Packages (+2 Dependent packages)

Total size: 31 M
Installed size: 133 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  package kernel-3.13.9-200.fc20.x86_64 (which is newer than kernel-3.11.10-301.fc20.x86_64) is already installed
  package kernel-3.13.10-200.fc20.x86_64 (which is newer than kernel-3.11.10-301.fc20.x86_64) is already installed
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-04-23 03:27:42 -0500

cobra gravatar image

updated 2014-04-23 03:28:29 -0500

There are two potential causes of this that I know about. Check them out and see if any apply:

  1. You might have another, incompatible software repository installed. If you've been provided with your current kernel from somewhere else, you might find that the one you're trying to install the current kmod-wl module for is incompatible. If this is the case, then removing the offending kernel and rebooting is probably the most sensible approach.

  2. It could be that the official repositories have just provided a new kernel and that rpmfusion haven't rebuilt their kmod packages yet. If this is the problem then you should just give it a day or two and try again. If it's not fixed in a few days, then ask the rpmfusion people about it. Sometimes (extremely rare) a kmod package gets missed from their build lists and you have to give them a nudge. I've done that twice in ten years of Fedora over the nVidia drivers.

You could, of course, download the source package. I believe rpmfusion also provide an auto-build package which provides the source code and will rebuilt the module on bootup to match your kernel (the certainly have this for the video drivers). This is much less convenient but it can work around such problems.

edit flag offensive delete link more

Comments

Thanks Cobra. I was triggerd with you're option 1 answer. I did a backup of all my data and re-installed from fresh. Then updated to the latest kernel and installed kmod-wl. Now my wireless is working again :-)

Anand J gravatar imageAnand J ( 2014-04-23 16:48:45 -0500 )edit

To prevent youself from being hit by @cobra's issue No. 2, install the packages akmods and akmod-wl from rpmfusion. akmods automatically build the relevant kernel modules for a new kernel.

cma gravatar imagecma ( 2014-04-29 02:02:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-23 03:01:35 -0500

Seen: 1,218 times

Last updated: Apr 23 '14