Ask Your Question
1

configure auto copy paste

asked 2014-05-26 12:09:23 -0500

mlw gravatar image

updated 2014-05-27 12:04:58 -0500

mether gravatar image

When I last ran Fedora (14 I think), I could hightlight some text, move the mouse pointer, click left/right together and the text would be pasted. Indeed this works on other Linuxs. I have installed Fedora 20 and now when I hightlight text, I have to click left to copy and when I click left/right together I get a menu, from which I have to select paste. Please tell me how can I configure the system to bypass the menu and the click to select? I think I had to change xorg.conf but this file isn't present on Fedora 20.

Thanks in advance fot your assistance.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-05-26 21:40:30 -0500

One way to configure this is with xinput :

list devices:

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:101a   id=8    [slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:2011   id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button

list mouse properties:

$ xinput list-props 8
Device 'Logitech Unifying Device. Wireless PID:101a':
    Device Enabled (144):   1
    Coordinate Transformation Matrix (146): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (273): 0
    .....   
    Evdev Scrolling Distance (282): 1, 1, 1
    Evdev Middle Button Emulation (283):    0
    `Evdev Middle Button Timeout (284): 50`
    Evdev Third Button Emulation (285): 0
    ...
    Evdev Drag Lock Buttons (294):  0

Adjust the property for a device:

$ xinput set-prop 283 1

You can set this up as a script to run on login, or use it to get the values to put into an xorg.conf.d snippet.

edit flag offensive delete link more

Comments

Thank you so much for your help! It is now working as I wanted. Brill!

mlw gravatar imagemlw ( 2014-05-27 02:57:30 -0500 )edit

@miw, please mark this answer as correct instead of editing the title of your question. Thanks!

mether gravatar imagemether ( 2014-05-27 12:06:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-26 12:09:23 -0500

Seen: 1,290 times

Last updated: May 27 '14