Ask Your Question
0

How can I get rid of this being written to my home folder C:\nppdf32Log\debuglog.txt?

asked 2014-06-17 10:13:29 -0500

updated 2014-09-30 15:08:37 -0500

mether gravatar image

I have had this problem before and that ended with me removing the Firefox Adobe Acrobat Reader plugin, as I recall. I was hoping there was a solution soon to this problem.

Problem: There is a file randomely written to the home folder named C:\nppdf32Log\debuglog.txt. I keep deleting it and I tried a fix where you insert /dev/null and then zero's for the remaining deleted characters with a hex editor. But it hasn't fixed it.

Is there any solution to this bug/problem/annoyance?

EDIT: After the fix in my answer it now writes this hidden file:".nppdf32Log.debuglog.txt" in my home folder :-(

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-06-24 17:44:27 -0500

updated 2014-06-28 00:51:13 -0500

I found a fix on this site, it's #24. Haven't seen if it works yet but I'm testing. Tested for five day's now, no file written. It works.

edit flag offensive delete link more

Comments

3

This solution proposes editing the .so file that contains the problem. It's far easier not to use the adobe pdf plugin. It really is redundant on Linux.

cobra gravatar imagecobra ( 2014-06-25 07:57:09 -0500 )edit
5

answered 2014-06-18 05:09:21 -0500

cobra gravatar image

It's not the flash plugin, but the adobe acrobat pdf reader.

There are so many different PDF readers available for Linux, I'm surprised anyone bothers with the bloatware that is Acrobat.

You should be able to fix it by uninstalling Acrobat Reader for Linux and selecting a different PDF reader from your package manager.

edit flag offensive delete link more

Comments

1

Just to mention, that I completely agree. Personally I work with evince.

NickTux gravatar imageNickTux ( 2014-06-18 10:36:16 -0500 )edit
0

answered 2014-06-18 10:33:23 -0500

liquidat gravatar image

There is not much you can do properly because Adobe Reader for Linux is not supported by Adobe and is thus not updated anymore.

The only thing I am aware of to fix that issue is a quick&dirty hack: locate the plugin (usually /usr/lib/mozilla/plugins/nppdf.so), make a backup of it, and change the file path to something not disturbing: sed -i 's/C:\nppdf32Log\debuglog.txt/\/dev\/null\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000\o000/' nppdf.so

That is a really ugly hack, but should work.

edit flag offensive delete link more

Comments

@liquidat Thank's. I've tried your hack. Time will tell if it works. Then you get +1.

somethingSomething gravatar imagesomethingSomething ( 2014-06-18 15:03:41 -0500 )edit

@liquidat Doesn't work. Sorry

somethingSomething gravatar imagesomethingSomething ( 2014-06-19 19:41:09 -0500 )edit

Alternatively, you could also open the file with an editor, find the aforementioned path, and replace it with Zeros. Please keep in mind that the browser has to re-load the plugin afterwards, so a full cold restart of the browser is necessary.

liquidat gravatar imageliquidat ( 2014-07-28 09:56:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-17 10:13:29 -0500

Seen: 2,516 times

Last updated: Jun 30 '14