Ask Your Question
0

Wireless not working on fedora 20

asked 2014-07-20 11:19:35 -0600

dstolfa gravatar image

updated 2014-07-20 19:18:23 -0600

FranciscoD_ gravatar image

I have recently reinstalled fedora 20 using the basic install, with the selection of the i3wm.

Ever since I did that, I had configured everything as I have previously and my broadcom wireless stopped working. My NetworkManager cannot detect any wireless points, eventhough I have one right next to me.

The output of my

lspci | grep Broad:
02:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)

uname -a:
Linux fedora 3.15.6-200.fc20.x86_64 #1 SMP Fri Jul 18 02:36:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

and

lsmod | grep wl:
wl                   6363566  0 
cfg80211              493377  1 wl

The kmod-wl, akmod-wl and broadcom-wl are from rpmfusion-non-free repo and they're made for 3.15.6.

edit retag flag offensive close merge delete

Comments

Also, try deleting akmod.

abadrinath gravatar imageabadrinath ( 2014-07-21 01:17:20 -0600 )edit

PS: This is a duplicate question of my question.

abadrinath gravatar imageabadrinath ( 2014-07-21 01:56:47 -0600 )edit

I have seen your question, however the responses have not helped me. I have modprobed wl and have tried getting rid of akmod, nothing helped. However, I have managed to fix it via a reinstall, I guess my installation failed the first time around without me realizing it.

dstolfa gravatar imagedstolfa ( 2014-07-22 14:11:00 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-23 01:58:51 -0600

abadrinath gravatar image

updated 2014-07-25 01:03:07 -0600

As you said, reinstalling worked, so I'll add it to the Wireless troubleshooting.

  • Reinstall
  • modprobe wl
  • Delete akmod and replace with kmod
  • Delete kmod and replace with akmod
  • Disable secure boot
  • Try with a live install of Ubuntu

Reinstalling

Step 1. Grab a spin of Fedora, and follow the Fedora Installation guide or one of many good tutorials:

http://docs.fedoraproject.org/en-US/Fedora/20/html/Installation_Guide/

http://www.if-not-true-then-false.com/2014/fedora-20-heisenbug-install-guide/

http://www.wikihow.com/Install-Fedora

http://www.fedoraforum.org/?view=fedora_setup

Step 2. After install, get the drivers by Google searching your card. Some famous ones:

Broadcom cards - yum install broadcom-wl

Broadcom cards - yum install b43-fcutter

Intel cards - yum install iwlwifi

Atheros cards - yum install ath5k

If none of these cards are yours, check out http://wireless.kernel.org/en/users/Drivers for a list of all drivers for the cards.

Step 3. Reboot!

Troubleshooting using modprobe wl

Step 1. Open a terminal and execute modprobe wl (or b43 for the other Broadcom cards).

Possible outputs:

modprobe: ERROR: could not insert 'wl': Operation not permitted
modprobe: ERROR: could not insert 'wl': Required key not available
modprobe: FATAL: Module wl not found.

The first one suggests that you might have to login as root. Try su, type in the root/administrator password and try again.

The second output suggests that there is a kernel signature error. This means that you might have to disable secure boot. To do that, go to the BIOS settings and head over to the section called Boot.

The last output suggests that you haven't install broadcom-wl or that the broadcom-wl driver is not suitable for your system. In that case, try a different driver.

Step 2. Try to troubleshoot using the above hints. Note: some of the things above may not work for your laptop and your specific card

Delete akmod and replace with kmod

Step 1. Sometimes, the problem is to do with both of these or the wrong one. To troubleshoot, delete the akmod package using the command:

yum erase akmod-wl #Do not forget the wl part

Step 2. Next, we will install kmod (optional):

 yum install kmod-wl

Step 3. Last, we can reboot to test changes:

reboot

Delete kmod and replace with akmod

Step 1. Sometimes, the problem is to do with both of these or the wrong one. To troubleshoot, delete the akmod package using the command:

yum erase akmod-wl #Do not forget the wl part

Step 2. Next, we will install kmod (optional):

 yum install kmod-wl

Step 3. Last, we can reboot to test changes:

reboot

Delete kmod and replace with akmod

Step 1. Sometimes, the problem is to do with both of these or the wrong one. To troubleshoot, delete the kmod package using the command:

yum erase kmod-wl #Do not forget the wl part

Step 2. Next, we will install akmod (optional):

 yum install akmod-wl

Step 3. Last, we can reboot to test changes:

reboot

Try with a different distro or operating system

Step ... (more)

edit flag offensive delete link more

Comments

@hello: the topic "Delete akmod and replace with kmod" was repeated twice!

anishjp gravatar imageanishjp ( 2014-07-24 09:29:53 -0600 )edit

@anishjp - thanks fixed LOL. BTW, only the title was messed up, not the content :)

abadrinath gravatar imageabadrinath ( 2014-07-25 01:04:33 -0600 )edit
0

answered 2014-07-24 05:58:35 -0600

trol1ed gravatar image

Also, try using a different kernel and if the issue persists.

edit flag offensive delete link more
0

answered 2014-07-27 14:12:17 -0600

sergiomb gravatar image

Hi, please address this rpmfusion packages problems to rpmfusion users mailing list

subscribe where :

http://lists.rpmfusion.org/mailman/listinfo/users

Thanks,

edit flag offensive delete link more
0

answered 2014-07-21 01:16:01 -0600

abadrinath gravatar image

modprobe wl? PS: You have the same card as me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-20 11:19:35 -0600

Seen: 14,479 times

Last updated: Jul 27 '14