Ask Your Question
0

What is the default setting for fonts in Fedora Gnome?

asked 2014-07-27 03:52:37 -0500

Ervin gravatar image

HI, I installe Iagno (reversi game) but after Iagno installation my fonts appearance changed (for worse),. Before the default Fedora fonts were quite ok. I messed with my system fonts using tweak tool, but I want to get back to the default fonts, I just don't remember them and there is no default option in tweak tool. I don't want to have to re-install the system just to fix the fonts. Thanks in advance, Ervin

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-09-14 04:18:52 -0500

Ervin-Reloaded gravatar image

updated 2015-09-14 04:21:12 -0500

This is how you reset the fonts in gnome. Run every command in the terminal, no need to run as root or sudo.

gconftool-2 --unset /desktop/gnome/interface/font_name

gconftool-2 --unset /desktop/gnome/interface/document_font_name

gconftool-2 --unset /desktop/gnome/interface/monospace_font_name

gconftool-2 --unset /apps/metacity/general/titlebar_font

gconftool-2 --unset /apps/nautilus/preferences/desktop_font

And then restart

edit flag offensive delete link more
1

answered 2014-07-27 05:46:30 -0500

abadrinath gravatar image

Try this answer here:

http://askubuntu.com/questions/4989/reset-gnome-font-configuration

and

http://askubuntu.com/questions/56313/how-do-i-reset-gnome-to-the-defaults

WARNING: the second one will destroy all custom data from tweak-tool, so back up if you need to back it up

Advice in future: Search the internet before you post in Ask because the answer is easy to find in Google.

edit flag offensive delete link more

Comments

Thank you, I did not try the first link, I tried the instructions in the second link, but then I ended up with my online accounts not working even after removing and adding them again.

Ervin gravatar imageErvin ( 2014-07-28 14:04:51 -0500 )edit

Why not the first link? The first link would have not reset the accounts. BTW, did the fonts work? Also, open another question for the online accounts if needed.

abadrinath gravatar imageabadrinath ( 2014-07-29 01:30:45 -0500 )edit

Thank you hello, the first one simply did not work.

Ervin gravatar imageErvin ( 2014-10-07 15:36:36 -0500 )edit
1

answered 2014-07-27 06:30:43 -0500

con flatulence gravatar image

the program "dconf-editor" seems to remember defaults so install that

yum install dconf-editor

The trouble is finding the name of the setting to tweak... looking at the gnome-tweak-tool font tweak source the font tweak modifies the keys in org.gnome.desktop.interface so in dconf-editor nagivate org->gnome->desktop->interface. Modified settings in dconf-editor are highlighted in bold, when you click on a setting the default value appears at the bottom of the window along with a set-to-default button. The relevant settings and defaults are:

Interface: font-name: 'Cantarell 11'
Documents: document-font-name: 'Sans 11'
Monospace: monospace-font-name: 'Monospace 11'
edit flag offensive delete link more

Comments

Thanks for the input. I did not try that method yet, but seems more interesting and better than the one described in the Ubuntu forums.

Ervin gravatar imageErvin ( 2014-07-28 14:06:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-27 03:52:37 -0500

Seen: 19,327 times

Last updated: Sep 14 '15