English
Ask Your Question
1

Eclipse(Kepler, Luna) crashed on F19, 20 even after removing the Google-talk-plug-in:

asked 2014-07-31 00:24:35 +0000

Kiran gravatar image

updated 2014-09-28 23:34:35 +0000

mether gravatar image

My eclipse is crashing on F19, F20 even after tried the work around proposed (removing the google-talk-plugin) in the Known Issues.

I am Currently on: Fedora 20 using Jdk1.7 with Eclipse - Luna

I tried the following different combinations. Nothing stopped the eclipse (Both Kepler and Luna) from crashing:

  • Fedora 19: with Jdk1.6 with Kepler
  • Fedora 19: with Jdk1.7 with Kepler
  • Fedora 19: with Jdk1.7 with Luna
  • Fedora 19: with Jdk1.8 with Luna
  • Fedora 20: with Jdk1.6 with Kepler
  • Fedora 20: with Jdk1.7 with Kepler
  • Fedora 20: with Jdk1.7 with Luna
  • Fedora 20: with Jdk1.8 with Luna I upgraded my fedora and tried all the above combinations in Fedora 20. No luck.

I am using Oracle's Java. When i set the java path in the bash, I can see the eclipse pick the right version.

Please, Suggest any debugging tips to find-out the root cause.

I tried running the eclipse from terminal, That did not give me any useful info and the .log file has nothing useful as well. Here is the log from eclipse: With jdk1.7:

!ENTRY org.eclipse.core.resources 2 10035 2014-07-30 16:57:52.321
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
!SESSION 2014-07-30 17:23:24.753 -----------------------------------------------
eclipse.buildId=4.4.0.I20140606-1215
java.version=1.7.0_65
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.standard.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.standard.product

With JDK1.8

!ENTRY org.eclipse.core.resources 2 10035 2014-07-30 19:46:32.093
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
!SESSION 2014-07-30 19:49:23.194 -----------------------------------------------
eclipse.buildId=4.4.0.I20140606-1215
java.version=1.8.0_11
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.standard.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.standard.product

Please, Let me know if you have any other suggestions and the issue causing the problem

edit retag flag offensive close merge delete

Comments

Works fine on mine (BTW, use eclipse a lot).

hello ( 2014-07-31 06:26:03 +0000 )edit

Also, what does the Gtalk plugin have to do with jdk/eclipse?

hello ( 2014-07-31 08:44:12 +0000 )edit

F20 has known issues with eclipse which are identified as root-cause for the libsoup Crash which intern crashes the eclipse when we try to access the javadoc/ auto-suggestions in eclipse.

Kiran ( 2014-08-05 17:22:55 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-08-01 17:20:51 +0000

I am aware of two known bugs in Eclipse. When Eclipse crashes it usually leaves a log file in the location where it is being run from or home folder. That might be more helpful.

Bug 1. libgobject Crash. This happens due in KDE when you use oxygen-gtk. The solution is to use some gtk theme.

Bug 2. libsoup Crash. This is the one related to google-talk-plugin. You don't have to remove google-talk-plugin. Just add the following line to your eclipse.ini.

-Dorg.eclipse.swt.browser.DefaultType=mozilla

My setup is Fedora 20 KDE with Oracle JDK 7u65 installed as noted here for Android development and I am using Eclipse Juno.

Bug report is here

PS:- What desktop environment are you running? and what are you using Eclipse for? If this doesn't help do post the log file that is dropped in your home folder or folder that has Eclipse.

edit flag offensive delete link more

Comments

Thank you for the answer. Updating the eclipse.ini file with the following helped my problem. -Dorg.eclipse.swt.browser.DefaultType=mozilla

I came to know about this from one my colleagues. Just like the Google-talk plugin, I have the Blue jeans plugin installed to facilitates the cross domain meetings (through Skype, G-Talk, Link and native) on the cloud which was causing this issue.

Thanks for your time and suggestion. I really appreciate it

Kiran ( 2014-08-05 17:20:47 +0000 )edit

Glad it works, @Kiran (sorry I couldn't help :( ).

hello ( 2014-08-05 23:07:06 +0000 )edit
0

answered 2016-05-15 21:20:49 +0000

Thank you sudhirkhange. It works. It helped me a lot..

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-07-31 00:24:35 +0000

Seen: 1,918 times

Last updated: Aug 01 '14