Ask Your Question
0

RPM/packages error.

asked 2014-08-11 14:53:21 -0500

adnanrashidpk gravatar image

updated 2014-08-11 15:19:46 -0500

mether gravatar image

Dear fellows.

hope you all are fine. when I excute yum update command I get these errors. please help me to solve them.

--> Finished Dependency Resolution

Error: Package: mesa-dri-drivers-9.2.4-1.20131128.fc19.x86_64 (@updates)
Requires: libLLVM-3.3.so()(64bit)
Removing: llvm-libs-3.3-4.fc19.x86_64 (@updates)
libLLVM-3.3.so()(64bit)
Updated By: llvm-libs-3.4.2-1.el7.x86_64 (epel)
~libLLVM-3.4.so()(64bit)
Available: llvm-libs-3.3-0.6.rc3.fc19.x86_64 (fedora)
libLLVM-3.3.so()(64bit)

Error: Package: mencoder-1.1-9.20130416svn.fc19.x86_64 (@rpmfusion-free-updates)
Requires: libass.so.4()(64bit)
Removing: libass-0.10.1-3.fc19.x86_64 (@fedora)
libass.so.4()(64bit)
Updated By: libass-0.10.2-2.el7.x86_64 (epel)
~libass.so.5()(64bit)
Available: libass-0.9.12-1.el6.nux.x86_64 (nux-dextop)
libass.so.4()(64bit)

Error: Package: mesa-libxatracker-9.2.4-1.20131128.fc19.x86_64 (@updates)
Requires: libLLVM-3.3.so()(64bit)
Removing: llvm-libs-3.3-4.fc19.x86_64 (@updates)
libLLVM-3.3.so()(64bit)
Updated By: llvm-libs-3.4.2-1.el7.x86_64 (epel)
~libLLVM-3.4.so()(64bit)
Available: llvm-libs-3.3-0.6.rc3.fc19.x86_64 (fedora)
libLLVM-3.3.so()(64bit)

Error: Package: mplayer-1.1-9.20130416svn.fc19.x86_64 (@rpmfusion-free-updates)
Requires: libass.so.4()(64bit)
Removing: libass-0.10.1-3.fc19.x86_64 (@fedora)
libass.so.4()(64bit)
Updated By: libass-0.10.2-2.el7.x86_64 (epel)
~libass.so.5()(64bit)
Available: libass-0.9.12-1.el6.nux.x86_64 (nux-dextop)
libass.so.4()(64bit)

Error: Package: 2:qemu-kvm-1.4.2-15.fc19.x86_64 (@updates)
Requires: qemu-system-x86 = 2:1.4.2-15.fc19
Removing: 2:qemu-system-x86-1.4.2-15.fc19.x86_64 (@updates)
qemu-system-x86 = 2:1.4.2-15.fc19
Updated By: 2:qemu-system-x86-2.0.0-1.el7.1.x86_64 (epel)
qemu-system-x86 = 2:2.0.0-1.el7.1
Available: 2:qemu-system-x86-1.4.2-3.fc19.x86_64 (fedora)
qemu-system-x86 = 2:1.4.2-3.fc19

Error: Package: 2:qemu-system-x86-2.0.0-1.el7.1.x86_64 (epel)
Requires: libiscsi.so.2()(64bit)

Error: Package: vlc-core-2.0.10-1.fc19.x86_64 (@rpmfusion-free-updates)
Requires: libass.so.4()(64bit)
Removing: libass-0.10.1-3.fc19.x86_64 (@fedora)
libass.so.4()(64bit)
Updated By: libass-0.10.2-2.el7.x86_64 (epel)
~libass.so.5()(64bit)
Available: libass-0.9.12-1.el6.nux.x86_64 (nux-dextop)
libass.so.4()(64bit)

Error: Package: ffmpeg-libs-1.2.7-1.fc19.x86_64 (@rpmfusion-free-updates)
Requires: libass.so.4()(64bit)
Removing: libass-0.10.1-3.fc19.x86_64 (@fedora)
libass.so.4()(64bit)
Updated By: libass-0.10.2-2.el7.x86_64 (epel)
~libass.so.5()(64bit)
Available: libass-0.9.12-1.el6.nux.x86_64 (nux-dextop)
libass.so.4()(64bit)

Error: Package: libgadu-1.12.0-0.5.rc3.fc19.x86_64 (@updates)
Requires: libprotobuf-c.so.0()(64bit)
Removing: protobuf-c-0.15-7.fc19.x86_64 (@fedora)
libprotobuf-c.so.0()(64bit)
Updated By: protobuf-c-1.0.1-1.el7.x86_64 (epel)
~libprotobuf-c.so.1()(64bit)

Error: Package: libgit2-glib-0.0.6-1.fc19.x86_64 (@updates)
Requires: libgit2.so.0()(64bit)
Removing: libgit2-0.19.0-1.fc19.x86_64 (@updates)
libgit2.so.0()(64bit)
Updated By: libgit2-0.21.1-1.el7.x86_64 (epel)
~libgit2.so.21()(64bit)

Error: Package: 2:qemu-common-2.0.0-1.el7.1.x86_64 (epel)
Requires: qemu-kvm-common

 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
edit retag flag offensive close merge delete

Comments

metter how you edit my post? I want to learn this that how you edit my code in proper way? some one told me to use fpast.org but I am unable to understand. I am trying but how to past here is making problem. please teach me. thanx

adnanrashidpk gravatar imageadnanrashidpk ( 2014-08-13 17:20:52 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-08-11 15:44:49 -0500

hedayat gravatar image

I've already answered you in the other question about skype. You have enabled EPEL repository on Fedora, which is wrong. You must disable or remove EPEL repository, e.g. using the following command (which is part of yum-utils package):

yum-config-manager --disable epel

(or you can remove the epel .repo file in /etc/yum.repos.d/)

edit flag offensive delete link more

Comments

yes you told me. but I am not familiar with commands. i tried yesterday but not succeeded. thanks again to highlighting my error.

adnanrashidpk gravatar imageadnanrashidpk ( 2014-08-11 15:50:12 -0500 )edit

Well, sorry about that. However, you could just tell me that you need more details :) Anyway, now you should be able to install the official Skype Fedora package easily (yes, download the Skype package for Fedora 16 in Skype website. It works fine even on Fedora 20).

hedayat gravatar imagehedayat ( 2014-08-11 15:55:57 -0500 )edit

yes my question is same that it is for fc16. now u already answered. one more question that my system is 64bit not 32bit. I know it works but i am just confirming. because i have data in this OS that i dont want to loss. if any problem occur. will it work?

adnanrashidpk gravatar imageadnanrashidpk ( 2014-08-11 16:06:03 -0500 )edit

No, that's fine! Skype doesn't have a 64bit version for GNU/Linux (IIRC the 'multiarch' packages for Ubuntu/Debian are also 32bit). I'll edit my answer to the other question so it is more clear.

hedayat gravatar imagehedayat ( 2014-08-12 01:40:46 -0500 )edit

can you tell me the commands and procedure to install skype? I downloaded it and its in my Download folder now. I tried according to readme file but not succeded. :(

adnanrashidpk gravatar imageadnanrashidpk ( 2014-08-12 08:48:12 -0500 )edit
1

answered 2014-08-11 15:45:12 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I solved this problem.

problem cause: I installed skype 4.3 and unfortunatly it was not working. gives error. because I followed Centos procedure. so the epel-release making problem.

solution: 1. yum clean all 2. yum update --skip-broken 3. rpm -qa |grep epel 4. yum remove epel-release.noarch 5. yum update

I solved it from diferent plateforms, by doing hit and try method and it works. If I did any thing wrong then please correct me. by the way my fedora19 working good now. :)

edit flag offensive delete link more

Comments

Actually step 4 was enough. And certainly removing epel-release is a good solution, so I voted your answer!

hedayat gravatar imagehedayat ( 2014-08-11 15:59:01 -0500 )edit

thanx bro. :)

adnanrashidpk gravatar imageadnanrashidpk ( 2014-08-11 16:03:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-11 14:53:21 -0500

Seen: 1,003 times

Last updated: Aug 11 '14