English
Ask Your Question
0

Does anyone know how to fix these dependency issues in yum?

asked 2014-08-18 16:54:17 +0000

updated 2014-09-28 15:41:53 +0000

mether gravatar image

When trying to update my system today, I got these errors:

--> Finished Dependency Resolution
Error: Package: 10:buildsys-build-rpmfusion-kerneldevpkgs-current-20-38.x86_64 (rpmfusion-free-updates)
           Requires: kernel-devel-uname-r = 3.15.9-200.fc20.x86_64
           Removing: kernel-devel-3.15.5-200.fc20.x86_64 (@updates)
               kernel-devel-uname-r = 3.15.5-200.fc20.x86_64
           Installed: kernel-devel-3.15.6-200.fc20.x86_64 (@updates)
               kernel-devel-uname-r = 3.15.6-200.fc20.x86_64
           Installed: kernel-devel-3.15.7-200.fc20.x86_64 (@updates)
               kernel-devel-uname-r = 3.15.7-200.fc20.x86_64
           Available: kernel-debug-devel-3.11.10-301.fc20.x86_64 (fedora)
               kernel-devel-uname-r = 3.11.10-301.fc20.x86_64+debug
           Available: kernel-debug-devel-3.15.10-200.fc20.x86_64 (updates)
               kernel-devel-uname-r = 3.15.10-200.fc20.x86_64+debug
           Available: kernel-devel-3.11.10-301.fc20.x86_64 (fedora)
               kernel-devel-uname-r = 3.11.10-301.fc20.x86_64
           Installing: kernel-devel-3.15.10-200.fc20.x86_64 (updates)
               kernel-devel-uname-r = 3.15.10-200.fc20.x86_64
Error: Package: kmod-VirtualBox-3.15.9-200.fc20.x86_64-4.3.14-1.fc20.4.x86_64 (rpmfusion-free-updates)
           Requires: kernel-uname-r = 3.15.9-200.fc20.x86_64
           Removing: kernel-3.15.5-200.fc20.x86_64 (@updates)
               kernel-uname-r = 3.15.5-200.fc20.x86_64
           Installed: kernel-3.15.6-200.fc20.x86_64 (@updates)
               kernel-uname-r = 3.15.6-200.fc20.x86_64
           Installed: kernel-3.15.7-200.fc20.x86_64 (@updates)
               kernel-uname-r = 3.15.7-200.fc20.x86_64
           Available: kernel-3.11.10-301.fc20.x86_64 (fedora)
               kernel-uname-r = 3.11.10-301.fc20.x86_64
           Installing: kernel-3.15.10-200.fc20.x86_64 (updates)
               kernel-uname-r = 3.15.10-200.fc20.x86_64
           Available: kernel-debug-3.11.10-301.fc20.x86_64 (fedora)
               kernel-uname-r = 3.11.10-301.fc20.x86_64+debug
           Available: kernel-debug-3.15.10-200.fc20.x86_64 (updates)
               kernel-uname-r = 3.15.10-200.fc20.x86_64+debug
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Can anyone point me in the right direction or show me how to fix? I don't have much experience with dependency problems.

My system is Fedora 20 and I have alot of sofware installed.

EDIT: It worked to do as suggested by yum: "--skip-broken"

Output (some of it):

--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    10:buildsys-build-rpmfusion-20-38.x86_64 from rpmfusion-free-updates
    10:buildsys-build-rpmfusion-kerneldevpkgs-current-20-38.x86_64 from rpmfusion-free-updates
    kmod-VirtualBox-4.3.14-1.fc20.4.x86_64 from rpmfusion-free-updates
    kmod-VirtualBox-3.15.9-200.fc20.x86_64-4.3.14-1.fc20.4.x86_64 from rpmfusion-free-updates

Dependencies Resolved

Now I get the same errors as before for the remaining packages:

~]$ sudo yum update
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, refresh-
              : packagekit, versionlock
adobe-linux-i386                                            |  951 B  00:00:00     
adobe-linux-x86_64                                          |  951 B  00:00:00     
home_tpokorra_mono                                          | 1.6 kB  00:00:00     
mysql-connectors-community                                  | 2.5 kB  00:00:00     
mysql-tools-community                                       | 2.5 kB  00:00:00     
mysql56-community                                           | 2.5 kB  00:00:00     
rpmfusion-free-updates                                      | 3.3 kB  00:00:00     
rpmfusion-nonfree-updates                                   | 3.3 kB  00:00:00     
tor                                                         | 2.9 kB  00:00:00     
tor-source                                                  | 2.9 kB  00:00:00     
updates/20/x86_64/metalink                                  |  29 kB  00:00:00     
virtualbox                                                  |  951 B  00:00:00     
Loading mirror speeds from cached hostfile
 * fedora: mirror.hmzkconsultingltd.com
* fedora-debuginfo: fedora.dcc.fc.up.pt
 * rpmfusion-free: www.fedora.is
 * rpmfusion-free-debuginfo: www.fedora.is
 * rpmfusion-free-updates: www.fedora.is
 * rpmfusion-free-updates-debuginfo: www.fedora.is
 * rpmfusion-nonfree: www.fedora.is
 * rpmfusion-nonfree-debuginfo: www.fedora.is
 * rpmfusion-nonfree-updates: www.fedora.is
 * rpmfusion-nonfree-updates-debuginfo: www.fedora.is
 * updates: ftp.ps.pl
 * updates-debuginfo ...
(more)
edit retag flag offensive close merge delete

Comments

Have you tried what the terminal output suggests ? sudo yum update --skip-broken and see if this fixes your problem. If not, post the new results. Edit your question and post them there, not here (at comments). Thanks.

NikTh ( 2014-08-18 17:59:45 +0000 )edit

@NikTh I've done what you suggested.

somethingSomething ( 2014-08-18 21:28:45 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
3

answered 2014-08-20 13:11:51 +0000

updated 2014-08-20 19:57:45 +0000

First, I'd suggest you to remove buildsys-build-rpmfusion-kerneldevpkgs-current package if you are unsure if you need it. You should actually don't need it unless you are really using it, which seems to be very unlikely.

yum remove buildsys-build-rpmfusion-kerneldevpkgs-current

And about kmod-VirtualBox package, as @hello said, rpmfusion kmod packages usually are a little behind the latest kernel in Fedora. I'd suggest you to install akmod-VirtualBox instead so that modules will be build for your running kernel. So, I'd suggest:

yum remove "kmod-VirtualBox*"
yum install akmod-VirtualBox
edit flag offensive delete link more

Comments

@hedayat Thanks for your solution. Though I don't have "kmod-VirtualBox-3.15.9-200 installed. For some reason I'm missing two kernels, kernel-3.15.8-200 and kernel-3.15.9-200. I think that's why "kmod-VirtualBox-3.15.9-200" has dependency problems. But I removed all "kmod-VirtualBox*" and use "akmod-VirtualBox" instead.

somethingSomething ( 2014-08-20 17:14:31 +0000 )edit

Oops, you are right. Yes, you shouldn't have that version of kmod-VirtualBox, it is what yum was trying to install from the repos as an update; so you needed to remove older versions of kmod-VirtualBox. I'll edit the answer accordingly.

hedayat ( 2014-08-20 19:56:51 +0000 )edit
2

answered 2014-08-18 20:19:34 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

using the skip-broken option probably isn't what you want - it will break your virtualbox software. For some reason the virtualbox and wl kernel modules sometimes lag the kernel releases in the Fedora repos. I'd suggest waiting a couple of days; the maintainers of the closed source drivers will catch up with the kernel version and yum will install the new kernel and the kernel module(s) that you need without needing any special yum switches. If you want to install everything that is available except for the new kernel (and the 'bad' virtualbox module) try:

yum upgrade --exclude=kernel* --exclude=kmod*

After a few days try a plain 'yum upgrade' to see whether the available module versions match the latest available kernel.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-08-18 16:54:17 +0000

Seen: 8,107 times

Last updated: Aug 20 '14