Ask Your Question
1

How to disable prelink in Fedora 20 KDE

asked 2014-08-22 09:06:22 -0500

updated 2014-08-22 14:45:36 -0500

Hello. Today i found, that prelink eats about 100 % my CPU, so i check processes with "top", and found, that it prelink fault, so want to safely disable prelink, or remove it. How i can safely remove prelink? By the way, i use Fedora 20 KDE spin. My machine spec.: Intel(R) Core (TM) i7 CPU 920 @ 2,67 GHz, 4 GiB ram memory, Nvidia GTX 650, with opensource drivers, kernel 3.15.10, KDE SC version 4.13.3. remove

edit retag flag offensive close merge delete

Comments

1

You might disable prelink as @cobra said, but doesn't it really worth it? First, prelink should not always use your CPU, but using it once a while is normal. And it is there for a reason. However, if your CPU is always busy with prelink, I'd kindly ask for a bug report.

hedayat gravatar imagehedayat ( 2014-08-23 02:25:29 -0500 )edit

@hedayat@cobra I am hearing about prelink for the first time. I am catching up on Gentoo and Arch wiki about it. How do I figure out if my system is using prelink or not? I am on Fedora 20 KDE.

sudhirkhanger gravatar imagesudhirkhanger ( 2014-08-24 04:22:55 -0500 )edit
1

Fedora uses prelink by default, to speed up process execution. And it should not be running always. It is run once per day by cron/anacron (/etc/cron.daily/prelink). So, you should not see it most of the time, just when it is being run by cron.

hedayat gravatar imagehedayat ( 2014-08-24 05:37:30 -0500 )edit

Thanks @hedayat. Arch Wiki recommends this echo export KDE_IS_PRELINKED=1 >> /etc/profile.d/kde-is-prelinked.sh. I am going to try if this helps speed up KDE start. Is it safe?

sudhirkhanger gravatar imagesudhirkhanger ( 2014-08-24 06:10:33 -0500 )edit

Hello, hedayat. I found this article https://fedorahosted.org/fesco/ticket/1183

minda gravatar imageminda ( 2014-08-24 09:29:27 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-08-24 09:09:05 -0500

sergiomb gravatar image

see https://bugzilla.redhat.com/show_bug.cgi?id=841434

you should do:

prelink -ua

before:

yum remove prelink
edit flag offensive delete link more

Comments

Thank you, Sergiomb, for the tip! For now, i turned off prelink with command "chkconfig prelink off" (as root). All work well.

minda gravatar imageminda ( 2014-08-24 09:25:52 -0500 )edit
3

answered 2014-08-22 15:22:41 -0500

cobra gravatar image

It should be safe just to turn it off. You can use the new systemctl stuff, but I always revert to the old method, which is wrapped to work with the new mechanism. Do this as root:

chkconfig prelink off

It is supposed to only run once at system load time and then quit until you next reboot - but if it's causing you problems then disabling rather than removing is safest.

If you want to remove it altogether then it doesn't seem to have any dependencies - try this as root:

yum remove prelink

Reboot and it'll be gone for good.

edit flag offensive delete link more

Comments

Thank you, cobra, for this tips. Today i turned off prelink, reboot machine, and all worked very well. By the way, i did a little research, and found, that prelink eat 100% CPU, when torrent client (qbittorrent) downloading a big file (about 2,5 GiB)....with Ktorrent all work well. Maybe this is bug, or something else. Anyway, thank you for the tips!

minda gravatar imageminda ( 2014-08-23 08:33:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-22 09:06:22 -0500

Seen: 2,286 times

Last updated: Aug 24 '14