Ask Your Question

vsftpd: What is the problem if i can connect to FTP from local network but get "No route to host" from remote machines?

asked 2014-08-30 15:13:37 +0000

Learning Linux gravatar image

updated 2014-08-30 15:14:40 +0000

I installed VSFTPD on Fedora 20 and i can connect to it from the same machine but when i try to connect from remote computer i get error "No route to host".

Temporally disabling SELinux did not help.


 tcp6       0      0 :::21                   :::*                    LISTEN      11406/vsftpd

VSFTPD configurations:

$ sudo cat /etc/vsftpd/vsftpd.conf | grep -v '^#'







edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-08-30 16:24:34 +0000

updated 2014-08-30 16:29:08 +0000

"No route to host" is a networking error indicating that your vsftpd host is operating on a subnet that cannot be reached by your client system. This could be the result of either a client or a server misconfiguration; what's the network topology in this situation? How do you believe your client should be able to reach the host (e.g. are they both connected to the same switch? Are they both operating over a home wireless router? etc.)?

If you don't know how to answer my question or where to begin, allow me to suggest that you post the output of the command traceroute6 vsftpdhost (I see that you are attempting to use IPv6 routing here) where "vsftpdhost" is the IP address or name of your FTP server, depending on how you're attempting to connect.

edit flag offensive delete link more


I think the problem is with the firewall. checking the open ports with a "port scanner" reviled that port 21 is closed. stopping the firewall with service firewalld stop and service iptables stop and setenforce 0 still shows the port is closed! How can it be that the port is closed if the firewall is down? is there several firewalls in Fedora by default? by the way: THANK YOU bitwiseoperator for the reply!

Learning Linux ( 2014-08-30 18:11:40 +0000 )edit

Ok, so Fedora 20 ships with both iptables and firewalld installed, but iptables is disabled by default whereas firewalld is enabled. You shouldn't run two firewalls simultaneously. The command setenforce 0 actually disables (well, it puts it into "permissive" mode, but for the purposes here, you can consider it to be disabled) SELinux on your machine, and that's not related to the firewall software, so you should re-enable SELinux right away (setenforce 1).

bitwiseoperator ( 2014-08-31 13:34:58 +0000 )edit

Would you mind checking out the output of the command I suggested executing (traceroute6 vsftpdhost) in addition to traceroute vsftpdhost (where, in both cases, vsftpdhost is the name or IP address of your FTP host system)? We need to know more about your network topology to figure out why your client system cannot find a route to your host system. It is unlikely that this is a firewall configuration issue (though such issues might exist, as well).

bitwiseoperator ( 2014-08-31 13:37:15 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

1 follower


Asked: 2014-08-30 15:13:37 +0000

Seen: 3,464 times

Last updated: Aug 30 '14