English
Ask Your Question
0

Trouble adding rpmfusion f21

asked 2014-10-04 14:31:02 +0000

Marko gravatar image

updated 2014-10-04 14:41:47 +0000

Hello, i'm new to Fedora and i'm having trouble with adding rpmfusion to Fedora 21. The way i was trying to enable free and non-free repos was the only way i found on rpmfusion.org :

su -c 'yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

and the console output is:

Loaded plugins: langpacks
rpmfusion-free-release-21.noarch.rpm                        |  15 kB  00:00     
Examining /var/tmp/yum-root-vkGpwX/rpmfusion-free-release-21.noarch.rpm: rpmfusion-free-release-21-0.1.noarch
/var/tmp/yum-root-vkGpwX/rpmfusion-free-release-21.noarch.rpm: does not update installed package.
rpmfusion-nonfree-release-21.noarch.rpm                     |  15 kB  00:00     
Examining /var/tmp/yum-root-vkGpwX/rpmfusion-nonfree-release-21.noarch.rpm: rpmfusion-nonfree-release-21-0.1.noarch
/var/tmp/yum-root-vkGpwX/rpmfusion-nonfree-release-21.noarch.rpm: does not update installed package.
Nothing to do

Any idea? Also i think i pasted this commands multiple times in last few days and who knows what else i did pasted. Then i cleared repolist (manually using nautilus) so now it looks like this:

repo id                    repo name                                      status
Education                  Applications for education users (Fedora_20)     772
adobe-linux-i386           Adobe Systems Incorporated                         2
adobe-linux-x86_64         Adobe Systems Incorporated                         2
*fedora/21/x86_64          Fedora 21 - x86_64                             42540
google-chrome              google-chrome                                      3
updates/21/x86_64          Fedora 21 - x86_64 - Updates                       0
updates-testing/21/x86_64  Fedora 21 - x86_64 - Test Updates               6240
repolist: 49559
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-10-05 06:50:05 +0000

updated 2014-10-05 06:51:55 +0000

su

dnf -y remove rpmfusion*

Next Reinstall rpmfusion... and enable rawhide rpmfusion...

edit flag offensive delete link more

Comments

thanks alot.

Marko ( 2014-10-09 23:35:12 +0000 )edit

How do I enable rawhide after reinstalling rpmfusion?

salamanderpie ( 2015-01-26 09:02:50 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2014-10-04 14:31:02 +0000

Seen: 3,928 times

Last updated: Oct 04 '14