English
Ask Your Question
4

How to improve fonts and font rendering in Fedora 20?

asked 2014-10-09 04:47:39 +0000

Gaurav Dighe gravatar image

updated 2014-10-09 05:31:18 +0000

mether gravatar image

Hello,

I have Fedora 20. The font / font rendering doesn't look great. I dont use Microsoft Fonts. I have tried Infinality, but still it doesn't look great. The font rendering in Linux Mint 17 is quite superb.

How to improve my font rendering and make it look elegant as it is in Linux Mint?

edit retag flag offensive close merge delete

5 answers

Sort by » oldest newest most voted
5

answered 2015-03-18 03:01:36 +0000

florian gravatar image

updated 2015-12-01 17:35:01 +0000

I decided to reflect the instructions to setup and configure subpixel font hinting as described here since there seems to be a demand for it. (Tested for F20, F21 and F22).

I think that Fedora with Gnome deserves a nice font, and I love the tweaked font using subpixel font hinting.

I am going to list the commands to achieve the result. For more information, please read the original post.

The command xrdb -query lists your (default) settings. Nice settings (as they are used in Ubuntu) are the following ones:

  • Xft.dpi: 96
  • Xft.antialias: 1
  • Xft.hinting: 1
  • Xft.hintstyle: hintslight
  • Xft.rgba: rgb
  • Xft.lcdfilter: lcddefault

Here is what you do:

1.) For subpixel rendering you need to install freetype-freeworld (sudo dnf install freetype-freeworld) from rpmfusion.

2.) You can use gnome-tweak-tool to set the hintstyle to slight and anti-aliasing-mode to rGBA.

3.) Activate lcdfilter: Unfortunately, there is no GSettings key for it. You have to create a hidden .Xresource file with the Xft.lcdfilter: lcddefault setting in your home directory. Run echo "Xft.lcdfilter: lcddefault" > ~/.Xresources.

4.) Logoff and logon again, and you will see the changes. Use xrdb -query to display your settings.

Have fun with (what I think is a nicer) Gnome!

EDIT (11/30/2015): (Thanks to @ILMostro): If you want those settings applied systemwide, you will have to edit /etc/X11/Xresources and add the needed parameters there (sudo gedit /etc/X11/Xresources).

edit flag offensive delete link more

Comments

Oops, should be >> not > in step 3, right? Thanks for your post!

Chris D'Amato ( 2015-10-19 10:22:28 +0000 )edit
1

You may be right. The difference between > and >> is that

  • echo "something" > file means that everything that's in "file" will be deleted, and "something" will be written to it (which means that "something" will be right at the beginning of "file".
  • echo "something" >> file means that "something" will be appended to "file", so nothing will be deleted from "file", and "something will be at the end of "file".

"file" will be created if it doesn't exist in both cases.

So, it really depends if .Xresources already exists and what's in there. I prefer using >. That way your are sure...

florian ( 2015-10-19 16:39:30 +0000 )edit
1

Maybe touch on the existence of the system-wide configuration files, e.g. /etc/X11/Xresources

ILMostro ( 2015-11-17 01:56:04 +0000 )edit

I've added Xft.hintstyle: hintslight, Xft.rgba: rgb, Xft.lcdfilter: lcddefault, and so on to /etc/X11/Xresources, but the login screen is still not affected. Please help me.

borntocode ( 2016-05-13 14:29:16 +0000 )edit
0

answered 2014-10-09 06:40:02 +0000

I have not used Mint, but usually I just enable autohintig and then it look good enough for me. To enable autohinting:

cd /etc/fonts/conf.d/
ln -s 10-autohint.conf /usr/share/fontconfig/conf.avail/10-autohint.conf

You have to do this as a root user.

edit flag offensive delete link more

Comments

I am getting error:

ln: failed to create symbolic link ‘/usr/share/fontconfig/conf.avail/10-autohint.conf’: File exists

Gaurav Dighe ( 2014-10-09 09:12:19 +0000 )edit

Ok. Then autohinting is already enabled. Maybe try what pnemade suggests?

mihkel ( 2014-10-09 14:37:46 +0000 )edit
1

You've got the order wrong in that ln command, which is why Gaurav is getting "File exists."

Try sudo ln -s /usr/share/fontconfig/conf.avail/10-autohint.conf /etc/fonts/conf.d/10-autohint.conf instead.

It didn't really improve my font rendering, though.

zanedp ( 2014-12-18 19:02:50 +0000 )edit
1

Try this: 1.) Install freetype-freeworld (sudo dnf install freetype-freeworld) from rpmfusion.

2.) Use gnome-tweak-tool to set the hintstyle to slight and anti-aliasing-mode to rGBA.

3.) Activate lcdfilter: Unfortunately, there is no GSettings key for it. You have to create a hidden .Xresource file with the Xft.lcdfilter: lcddefault setting in your home directory. Run echo "Xft.lcdfilter: lcddefault" > ~/.Xresources

4.) Logoff and logon again, and you will see the changes. Use xrdb -query to display your settings.

florian ( 2015-03-19 16:30:52 +0000 )edit
0

answered 2014-10-10 08:24:11 +0000

jmcknight gravatar image

I've found that enabling the RPM Fusion repo then installing the freetype-freeworld package gives nice results without having to fiddle with settings.

edit flag offensive delete link more
0

answered 2014-10-09 09:27:42 +0000

pnemade gravatar image

I can suggest one answer here. Install gnome-tweak-tools package. Choose Fonts tab from left side. There is a Hinting. Just change it and see what settings is compatible/gives rendering fine for your selected font.

edit flag offensive delete link more
-1

answered 2015-06-16 08:56:30 +0000

ardian gravatar image

You can also use Fedy https://satya164.github.io/fedy/ there is a fix for better fonts in the options.

edit flag offensive delete link more

Comments

http://folkswithhats.org/ (Fedy link-- yours is broken ;-)

elvisn ( 2015-12-02 19:16:44 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-10-09 04:47:39 +0000

Seen: 20,955 times

Last updated: Dec 01 '15