Ask Your Question
1

How to fix yum update [Errno 14] HTTP Error 404-not found

asked 2014-10-20 18:04:39 -0500

BlacqueDr8gon gravatar image

updated 2014-10-21 13:37:24 -0500

mether gravatar image

Greetings am Linux Newbie. The following error persist when executing yum update. Is this error a simple fix?

http://download.opensuse.org/repositories/home%3A/snwh%3A/moka-gtk-theme/Fedora_20/repodata/repomd.xml : [Errno 14] HTTP Error 404 - Not Found

Order of operation:

yum clean all

Loaded plugins: langpacks

Cleaning repos: rhughes-f20-gnome-3-12-x86_64 rhughes-f20-gnome-3-12-i386 : adobe-linux-x86_64 elegance-colors fedora fedora-skype fedy : gtk-theme-config infinality infinality-noarch livna : moka-gtk-theme moka-icon-theme puppetlabs-deps : puppetlabs-products rpmfusion-free rpmfusion-free-updates : rpmfusion-nonfree rpmfusion-nonfree-updates updates virtualbox Cleaning up everything

sudo yum update

[sudo] password for blacquedr8gon:

Loaded plugins: langpacks

http://download.opensuse.org/repositories/home%3A/snwh%3A/moka-icon-theme/Fedora_20/repodata/repomd.xml : [Errno 14] HTTP Error 404 - Not Found Trying other mirror.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-10-20 18:15:02 -0500

rsc gravatar image

If I visit http://download.opensuse.org/repositories/home%3A/snwh%3A/ (which is a parent directory of the URL you posted) it seems to turn out that the repository is simply not available anymore, like the error message says: 404 not found. However there is http://download.opensuse.org/repositories/home%3A/snwh%3A/moka-cinnamon-theme/Fedora_20/home:snwh:moka-cinnamon-theme.repo available (but I don't know if it is has same content).

If the new repository from my second link contains the correct content, you could for example use "su -c 'yum-config-manager --add-repo http://download.opensuse.org/repositories/home%3A/snwh%3A/moka-cinnamon-theme/Fedora_20/home:snwh:moka-cinnamon-theme.repo'" (without the "") to add this as new repository in yum.

Don't forget to at least disable the old repository, e.g. by using "yum-config-manager --disable moka-gtk-theme" (this name is guessed, use ideally something like "yum repolist all" before to figure out the correct name of the repository). Removing the old repository could be done using "su -c 'rm -f /etc/yum.repos.d/moka-gtk-theme.repo'" (without the "") if the repository name matches.

edit flag offensive delete link more

Comments

Advice and direction appreciated. Did suggested . Removed the Moka URL. No longer experiecing reported problem,,, Thank you very much!

BlacqueDr8gon gravatar imageBlacqueDr8gon ( 2014-10-20 21:24:04 -0500 )edit

Advice and direction appreciated.

Did as suggested .

Removed the Moka URL. su -c 'rm -f /etc/yum.repos.d/moka-gtk-theme.repo

No longer experiecing reported problem,,,

Thank you very much!

BlacqueDr8gon gravatar imageBlacqueDr8gon ( 2014-10-20 21:26:08 -0500 )edit

Could you then please mark my reply as the correct answer? Thank you.

rsc gravatar imagersc ( 2014-10-21 18:10:45 -0500 )edit

Excellent answer, thank you rsc for the correct answer. Sorry I can neither upvote nor mark as correct.

Mz.Donna gravatar imageMz.Donna ( 2016-01-08 12:43:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-20 18:04:39 -0500

Seen: 12,213 times

Last updated: Oct 20 '14