English
Ask Your Question
6

Steam on Fedora 21: OpenGL GLX error

asked 2014-10-24 11:30:19 +0000

After updating to Fedora 21, all 32 bits 3D games fail to run. Steam warns with this message at initialization:

OpenGL GLX context is not using direct rendering, which may cause performance problems.
For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457.

For more information see this forum post: http://forums.fedoraforum.org/showthread.php?t=300832

Anyone has a clue about how to fix this? Thank you.

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
11

answered 2014-10-24 13:00:34 +0000

Alejandro Nova gravatar image

This script works.

#!/bin/bash
DIR=$HOME/.local/share/Steam/

echo "Removing libstd"
find $DIR -iname "libstd*" -exec rm -rf {} \;

echo "Removing libgcc"
find $DIR -iname "libgcc*" -exec rm -rf {} \;

echo "All Done"
edit flag offensive delete link more

Comments

That actually worked.

Mr. G ( 2014-10-29 19:26:37 +0000 )edit

Fantastic. Thank you.

jorti ( 2014-10-30 17:06:03 +0000 )edit
1

Can you tell us why you did that? It's great that it worked, but what is the point of removing all of those C libraries?

captbrogers ( 2014-12-13 20:16:00 +0000 )edit

Having just carried out a fresh install of Fedora 21, this solution to the Steam problem really helped. Thanks. ++Karma all round.

cobra ( 2014-12-14 19:09:33 +0000 )edit
3

Steam bundles its own runtime environment. It seems their libraries are too old, and removing those files makes Steam to load the Fedora ones

jorti ( 2014-12-18 12:22:54 +0000 )edit
4

answered 2015-01-17 12:13:23 +0000

becks21 gravatar image

My solution was simply to install the "xorg-x11-drv-nvidia-libs.i686" package (and dependencies), since the Steam-Browser is a .i686 application and my system is .x86_64.

edit flag offensive delete link more

Comments

Thanks, that solved the problem for me

izambl ( 2015-01-17 20:57:19 +0000 )edit

This is the solution for 64 Bit fedora 21

Bijju ( 2015-01-19 17:45:36 +0000 )edit

Great! This was the final step getting steam working for me. 1st script from Aniship in the "rpm fusion" query. 2nd Alejandro's script above. 3rd somewhatparanoid's comment below. Your solution made it possible to play the games. Thanks to all, mucho Karma.

Warren ( 2015-04-18 19:17:09 +0000 )edit

@Bijju: the OP stated that all 32bit games fail to run, this implies 64bit would be working. Hence installing the 32bit xorg driver is obvious. @Warren: you're welcome. On my system (Fedora 21 64bit) I did not need to carry out any of the other mentioned steps. besides the currently most voted solution to delete libstd* and libgcc* files seems not to be a good solution.

becks21 ( 2015-04-18 22:30:31 +0000 )edit

it worked well! Thank, but this means the computer will use 32 bits process to video cards ?

Tyriel ( 2015-05-16 21:44:05 +0000 )edit
1

answered 2014-12-12 18:57:04 +0000

Bodanel gravatar image

Worked like a charm. Thks.

edit flag offensive delete link more
0

answered 2015-03-27 09:58:04 +0000

mikaelbrun gravatar image

A noob question

How do I use this script? :-) Do I have make a file? What kind of format? How to run it?

Teach me!

edit flag offensive delete link more

Comments

Sorry for the late answer.

Use your favorite text editor (gedit will suffice) to make a file called fix_steam.sh in your home directory (/home/your username/). Copy the script inside that file and save it (remember - under your home directory so that it's easily accessible via terminal). Open the terminal (Activities -> type "Terminal") and type chmod +x fix_steam.sh - this will make it so that you can execute your script. After that, type ./fix_steam.sh - don't forget the dot and the slash, as it tells your system to execute the script that's in your current directory. That's it!

somewhatparanoid ( 2015-04-04 12:00:15 +0000 )edit
0

answered 2015-07-10 09:37:45 +0000

shadowhh32 gravatar image

The fix for 22 seems equally to apply here as well. You should LD_PRELOAD the correct files as these files mentioned here in the script get overridden by steam itself.Steam will eventually replace these files occasionally and the bug will reappear.There is already a script out there that preloads the proper GCC libs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-10-24 11:30:19 +0000

Seen: 12,544 times

Last updated: Jul 10 '15