Ask Your Question
1

VLC not installing on Fedora 20

asked 2014-10-24 13:46:01 -0500

Noorani gravatar image

updated 2014-10-26 05:39:16 -0500

FranciscoD_ gravatar image

Can someone please help me to install VLC on Fedora 20 ?

when i do, yum install vlc

the following error:

--> Finished Dependency Resolution
Error: Package: vlc-core-2.1.5-5.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libass.so.5()(64bit)
Error: Package: vlc-core-2.1.5-5.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libgcrypt.so.20()(64bit)
Error: Package: ffmpeg-libs-2.4.2-1.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libass.so.5()(64bit)
Error: Package: vlc-core-2.1.5-5.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
Error: Package: vlc-2.1.5-5.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
Error: Package: vlc-core-2.1.5-5.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libgcrypt.so.20(GCRYPT_1.6)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

when i do:

yum --disablerepo=rpmfusion-free-rawhide --enablerepo=rpmfusion-free-updates install vlc-core

--> Finished Dependency Resolution
Error: Package: ffmpeg-libs-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libmp3lame.so.0()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libdvbpsi.so.9()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libtwolame.so.0()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libgroupsock.so.1()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libdca.so.0()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libliveMedia.so.17()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libBasicUsageEnvironment.so.0()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libUsageEnvironment.so.1()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libmpeg2.so.0()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: live555(x86-64) = 2013.11.26
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libx264.so.138()(64bit)
Error: Package: ffmpeg-libs-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libxvidcore.so.4()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libmad.so.0()(64bit)
Error: Package: vlc-core-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: liba52.so.0()(64bit)
Error: Package: ffmpeg-libs-2.1.5-1.fc20.x86_64 (rpmfusion-free-updates)
           Requires: libx264.so.138()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-10-24 14:06:49 -0500

skytux gravatar image

Please, disable rpmfusion-free-rawhide, it is the cause of the inconsistency in your system.

edit flag offensive delete link more

Comments

Once disabled, a yum distro-sync would also probably be a good idea - to get the system back in shape.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-26 05:38:37 -0500 )edit
1

Really, a good idea!

skytux gravatar imageskytux ( 2014-10-26 06:05:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-24 13:46:01 -0500

Seen: 1,412 times

Last updated: Oct 24 '14