Ask Your Question
0

How I can change logon wallpaper in fedora 20

asked 2014-10-27 12:18:51 -0500

Vijay Khurava gravatar image

updated 2014-10-27 21:54:14 -0500

mether gravatar image

Hi,

I want to change logon wallpaper in fedora 20 mate enabled Desktop. I tried to google it but results come up for modifying gnome-control-center setting using gdm but when I put those command lines in my machines then the resulls come in error as "Couldn't exec gnome-control-center: No such file or directory"

below is the command which I tried: sudo -u gdm dbus-launch gnome-control-center

edit retag flag offensive close merge delete

Comments

It sounds as though you don't have gnome-control-center installed. Run yum list installed gnome-control-center to find out. If not, sudo yum install gnome-control-center will install it, after which you can try again. (I'm not sure if that's the right way to do what you need, and don't run either gnome nor Mate, so I'm not entering this as an answer, although that might change if it turns out to be what you need.)

sideburns gravatar imagesideburns ( 2014-10-27 20:50:18 -0500 )edit

I am using mate desktop env. hence still would required to install gnome control center ? I choose Mate as its alt. to Gnome 2 and I have enabled multiple compiz settings on it so I have one more question if I install gnome control center will it bring me to normal desktop without any compiz & other settings.

Vijay Khurava gravatar imageVijay Khurava ( 2014-10-28 01:09:13 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-10-29 13:54:39 -0500

Vijay Khurava gravatar image

I managed to change login wallpaper by replacing below file with my desired one but its not setting what I really want.. even after replacing this file, file split into pieces.

/usr/share/gnome-shell/theme/noise-texture.png

edit flag offensive delete link more
0

answered 2014-10-27 23:26:48 -0500

mclmmc gravatar image
cat << eof > /etc/dconf/gdm.d/01-backgound
[org/gnome/desktop/background]
picture-uri='file:///path/of/your/background/image'
eof

dconf update

Read the RHEL 7 and ArchLinux documentation for more info or search google for "/etc/dconf/db/gdm.d"

edit flag offensive delete link more

Comments

thanks but as I earlier stated in my problem description I dont think I have GDM installed, also not sure which DM i am using. However I refer to your shared location path but there is nothing called gdm in /etc/dconf

Vijay Khurava gravatar imageVijay Khurava ( 2014-10-28 01:11:05 -0500 )edit

What does yum show when you run this: yum list installed gdm You probably have it because it's the default display manager for Gnome, and Mate is a fork of Gnome 2.

sideburns gravatar imagesideburns ( 2014-10-28 01:31:27 -0500 )edit

hmmm its installed but i dont understand what is wrong with it... Below are the results.

Loaded plugins: langpacks, refresh-packagekit home_paolorotolo_numix 6/6 Installed Packages gdm.x86_64 1:3.10.0.1-1.fc20 @fedora

Vijay Khurava gravatar imageVijay Khurava ( 2014-10-28 03:20:30 -0500 )edit

It's possible that you have more than one display manager installed and that another one's active. Run this command: systemctl list-unit-files | grep dm.service and see if there's more than one listed. You should see that gdm.service is enabled and any other display managers aren't.

sideburns gravatar imagesideburns ( 2014-10-28 14:59:35 -0500 )edit

Hi, Yes gdm is only one which is installed in my laptop & in active status, below is the result- gdm.service enabled Though I am not much technical for linux but I think the most of the solutions are based on pervious versions of fedora but in fedora the file structure is changed... which could the possible reason for not executing those commands.

Vijay Khurava gravatar imageVijay Khurava ( 2014-10-29 00:40:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-10-27 12:18:51 -0500

Seen: 1,627 times

Last updated: Oct 29 '14