English
Ask Your Question
0

Problem installing xorg-x11-server-devel on x86_64 Fedora 21

asked 2014-11-29 01:30:45 +0000

Jacek gravatar image

I am trying to install xorg-x11-server-devel package on Fedora 21 (x86_64) but yum wants to install dependency for i686 architecture which clashes with x86_64 version. How can I solve this problem? Full optput:

[jacek@nibbler ~]$ sudo yum install xorg-x11-server-devel
...
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-server-devel.x86_64 0:1.16.1-1.fc21 will be installed
--> Processing Dependency: pkgconfig(pixman-1) >= 0.27.2 for package: xorg-x11-server-devel-1.16.1-1.fc21.x86_64
--> Processing Dependency: pkgconfig(pciaccess) >= 0.12.901 for package: xorg-x11-server-devel-1.16.1-1.fc21.x86_64
--> Processing Dependency: pkgconfig(dri) >= 7.8.0 for package: xorg-x11-server-devel-1.16.1-1.fc21.x86_64
--> Processing Dependency: pixman-devel for package: xorg-x11-server-devel-1.16.1-1.fc21.x86_64
--> Processing Dependency: libpciaccess-devel for package: xorg-x11-server-devel-1.16.1-1.fc21.x86_64
--> Running transaction check
---> Package libpciaccess-devel.x86_64 0:0.13.3-0.3.fc21 will be installed
---> Package mesa-libGL-devel.x86_64 0:10.3.3-1.20141110.fc21 will be installed
--> Processing Dependency: pkgconfig(xshmfence) >= 1.1 for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xcb-glx) >= 1.8.1 for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xcb-dri2) >= 1.8 for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(libdrm) >= 2.4.38 for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xxf86vm) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xfixes) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xext) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xdamage) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xcb-sync) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xcb-present) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(xcb-dri3) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(x11-xcb) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: pkgconfig(x11) for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
--> Processing Dependency: gl-manpages for package: mesa-libGL-devel-10.3.3-1.20141110.fc21.x86_64
---> Package pixman-devel.x86_64 0:0.32.6-4.fc21 will be installed
--> Running transaction check
---> Package gl-manpages.noarch 0:1.1-9.20140424.fc21 will be installed
---> Package libX11-devel.x86_64 0:1.6.2-2.fc21 will be installed
---> Package libXdamage-devel.x86_64 0:1.1.4-6.fc21 will be installed
---> Package libXext-devel.x86_64 0:1.3.3-2.fc21 will be installed
---> Package libXfixes-devel.x86_64 0:5.0.1-4.fc21 will be installed
---> Package libXxf86vm-devel.x86_64 0:1.1.3-4.fc21 will be installed
---> Package libdrm-devel.x86_64 0:2.4.58-1.fc21 will be installed
--> Processing Dependency: libdrm = 2.4.58-1.fc21 for package: libdrm-devel-2.4.58-1.fc21.x86_64
---> Package libxcb-devel.x86_64 0:1.11-2.fc21 will be installed
--> Processing Dependency: pkgconfig(xau) >= 0.99.2 for package: libxcb-devel-1.11-2.fc21.x86_64
---> Package libxshmfence-devel.x86_64 0:1.1-3.fc21 will be installed
--> Running transaction check
---> Package libXau-devel.x86_64 0:1.0.8-4.fc21 will be installed
---> Package libdrm.i686 0:2.4.58-1.fc21 will be installed
--> Processing Dependency: libpciaccess.so.0 for package: libdrm-2.4.58-1.fc21.i686
--> Processing Dependency: libc.so ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-29 12:37:36 +0000

pnemade gravatar image

updated 2014-11-29 12:38:27 +0000

I have not looked into detail above but only last line and can think that you already got newer version of libdrm installed and some package want old libdrm. This may happen when you disable testing repo and tries to install/update any packages on your system. Downgrade libdrm using

yum downgrade libdrm

to have its version 2.4.58-1.fc21 and then use your yum install command.

edit flag offensive delete link more

Comments

That works. Thank you very much.

Jacek ( 2014-11-29 19:57:53 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2014-11-29 01:30:45 +0000

Seen: 2,343 times

Last updated: Nov 29 '14