English
Ask Your Question
5

Unable to boot fedora 21 Live USB (vesamenu.c32: not a COM32R image error)

asked 2014-12-13 18:32:25 +0000

deadrat gravatar image

updated 2017-01-13 21:39:11 +0000

mattdm gravatar image

I downloaded the Fedora 21 iso image from : http://download.fedoraproject.org/pub...64/iso/Fedora-Live-Workstation-x8664-21-5.iso

I used liveusb-creator (in Win 10) to create live USB. (Instructions can be found here: http://libre.bigbangnerd.com/2015/01/... )

I am unable to boot now.

I get an error message

vesamenu.c32: not a COM32R image
boot:

I am not sure what to do.

Thanks.

edit retag flag offensive close merge delete

Comments

1

This just happened to me today as i was trying to boot an install media on USB. The solution as suggested below was I copied the vesamenu.c32 from an existing Fedora OS install (Fedora19) in /usr/share/syslinux and replaced the one on the USB drive inside the syslinux folder. This solved my problem.

koladapo ( 2015-02-24 20:05:05 +0000 )edit

Still happens in v22, and copying the file seems to do nothing in this case. Typing linux0 allowed the live USB to boot ok, as far as i can see. The USB boot creator for Windows was used to make the boot USB, and it looks rather old (it has the option to download fedora, but the newest version to choose was v18, i just told the creator to use an already downloaded image of v22).

fsr ( 2015-06-10 15:51:43 +0000 )edit

So if you are not able to boot using Live USB because of the above issue,hit tab.Itwill give available options


@fsr , I agree. The developers haven't updated the liveusb-creator in a while. not that it needs a major update, but they could add the options to download the latest fedora releases.

deadrat ( 2015-06-13 13:07:19 +0000 )edit

I have the same problem now and it appears to have destroyed my USB drive to as I cannnot mount it in anyway !

Orriginal ( 2015-09-15 15:36:38 +0000 )edit

It still happens with Fedora 24 installators. I do not get which Tab menu you are talking about (nothing appears for me). The vesamenu.c32 was fine in Fedora17 /lib/syslinux but not in is wrong in Fedora 24 /usr/share/syslinux. So, you cannot fix installer now by manual copy. I do not understand which Tab menu you are talking about (nothing appears to me besides more errors, yet memtest command is runnable). I also do not understand why you attribute the wrong file to the LIveUSB creator rather than .iso image that contains it.

valtih1978 ( 2016-06-30 07:56:15 +0000 )edit

4 answers

Sort by ยป oldest newest most voted
7

answered 2014-12-14 17:23:41 +0000

deadrat gravatar image

updated 2015-04-07 16:37:24 +0000

One of my friend had a same issue with Debian. It can be easily solved.

  1. hit TAB : the installer will show a list of possible options.
  2. type the correct image name (it is case sensitive)
  3. Hit ENTER

I had options like linux0, basic0, check0, memtest, local, returntodomain. I chose linux0 and it boots properly.

If you are looking for a permanent solution: You may try deleting the vesamenu.c32 file on the USB drive, and replacing it with the most recent local version (located at /usr/lib/syslinux).

edit flag offensive delete link more

Comments

Please click the tick mark on your answer to mark this question as solved

TheDcoder ( 2014-12-15 09:28:15 +0000 )edit

Okay, thanks.

deadrat ( 2014-12-15 13:06:15 +0000 )edit

I'm having the same problem. Hitting the TAB key didn't work for me, but when I type "linux0" at the "boot:" prompt my machine boots. Is there some way to find and fix the "vesamenu.c32" file? There doesn't seem to be one in the "/usr/lib/syslinux" folder.

nat_g ( 2015-02-24 19:57:33 +0000 )edit

For Fedora, the vesamenu file is in /usr/share/syslinux

koladapo ( 2015-02-24 20:06:18 +0000 )edit

If the permanent solution is to replace the vesamenu.c32 file on the USB drive. If the most recent local version is in the /usr/share/syslinux folder where is the version that needs to be replaced?

nat_g ( 2015-02-25 19:29:50 +0000 )edit
0

answered 2015-04-03 05:13:37 +0000

Hit TAB Key and select "linux0". This worked for me.

edit flag offensive delete link more

Comments

Like a GOD haha i dit it and resuts :p

acsantosac ( 2015-11-18 21:51:24 +0000 )edit

works for fedora 23 also

gplayersv ( 2015-12-12 11:09:24 +0000 )edit
0

answered 2016-09-16 14:28:03 +0000

RogerP gravatar image

I get the same error. TAB does not work. What good is this? Why doesn't anyone fix it?

Chimps on a keyboard!

edit flag offensive delete link more

Comments

This question was asked for fedora 21. What ISO are you using? If the issue still occurs, we can update the question and try to find a solution.

And how did you create the live media?

deadrat ( 2016-09-20 13:58:24 +0000 )edit
0

answered 2016-11-21 21:32:18 +0000

DMX gravatar image

Still the same in Fedora 24 !!!!!!!!!!! How come, guys, this still hasn't be fixed :-((((( There is ZERO chance to make a first good impression on this OS. I wish this would be happening to everyone who tries to install Windows 10, while actually, it has been a bug, introduced in Windows 98...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-12-13 18:32:25 +0000

Seen: 42,041 times

Last updated: Jan 13