English
Ask Your Question
0

How to install AMD APU Driver for Fedora 21

asked 2014-12-16 06:36:59 +0000

Xybrek gravatar image

updated 2014-12-16 19:30:29 +0000

I just finished installing Fedora 21 (Fresh install) the graphics is OK but it is stuck with 1024x768 resolution.

How can I install the driver for my old AMD A6-5400K? Do I need to install the proprietary AMD Catalyst Driver or there is nother way around?

Update:

I can do this when Fedora has booted and desktop is ready to adjust the resolution:

sudo xrandr --newmode "1440x900_59.90" 106.29 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync sudo xrandr --addmode VGA1 1440x900_59.90

However this is very repetitive each time.

edit retag flag offensive close merge delete

Comments

Are you opposed to the installation of the AMD Catalyst driver? In my experience, it's a far better solution than the open source drivers (though they are getting better). I have an AMD A10-6800k APU and it works well with the Catalyst driver - the only problem that is a show-stopper for some is the requirement that you use a Desktop Environment other than GNOME, since the Catalyst driver doesn't work with Fedora's GNOME packages.

bitwiseoperator ( 2014-12-17 14:21:18 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-12-16 09:59:56 +0000

cobra gravatar image

I have an AMD A8 with built in graphics and it gives me full 3D acceleration without additional driver support, very similar to your A6. You shouldn't need different drivers, but check check in your package manger that you've got OpenGL support installed.

It is more likely that your monitor configuration is not being detected properly. If you look in your Gnome configuration or in the Control Center (depending on the desktop environment you have installed) you should be able to edit the monitor settings and force it to be something more suitable.

edit flag offensive delete link more

Comments

Yes I can do: sudo xrandr --newmode "1440x900_59.90" 106.29 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync sudo xrandr --addmode VGA1 1440x900_59.90

However I have to do this everytime

Xybrek ( 2014-12-16 19:29:29 +0000 )edit
0

answered 2014-12-17 00:56:50 +0000

ahalverson gravatar image

updated 2014-12-17 02:07:28 +0000

As you mentioned at the bottom of your post, there is a command for adding resolutions. To kill the monotony: write a shell script(with the command in it) then set it to be run at startup in your desktop environment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-12-16 06:36:59 +0000

Seen: 3,184 times

Last updated: Dec 17 '14