English
Ask Your Question
1

Upgrading to Fedora 21 failed and caused kernel panic for Fedora 20, bricking my system

asked 2014-12-17 03:09:09 +0000

jflory7 gravatar image

updated 2015-11-11 04:32:23 +0000

mether gravatar image

I have been trying to get Fedora 21 running on my desktop for the past week, but I have been running into all kinds of issues with kmod-nvidia and my graphics card. Whenever I try booting into System Upgrade in GRUB (created by fedup), I instantly receive a black screen and I am forced to reboot.

I was on #fedora IRC and I was given the advice to remove the kmod-nvidia packages via YUM, upgrade, and then reinstall. I tried doing that with no success. After booting back into Fedora 20, I reinstalled the drivers, reexecuted fedup, and tried rebooting for good measure.

After getting the same results as before, I restarted my computer to see only the few kernel options present in GRUB - none of the System Upgrade options like before.

Immediately upon choosing any of the available kernels, I am greeted with this message. (I apologize for quality but I am working off my phone right now.)

Kernel Panic!

Any help is greatly appreciated as I'm virtually without a system.

Edit #1

On #fedora IRC, I was told to install simple-storage-manager and provide its output, which I have done so here.

edit retag flag offensive close merge delete

Comments

How did you remove the kmod-nvidia packages? Once you removed them, did you reboot into the same kernel to make sure things were working right?

sideburns ( 2014-12-17 03:40:26 +0000 )edit

@sideburns: I removed the kmod-nvidia packages via YUM. Once I removed them, I rebooted into the System Upgrade with no success. Then I successfully rebooted into the old kernel version and it did load successfully.

jflory7 ( 2014-12-17 09:47:59 +0000 )edit

what hardware did you have ? is it a new or a old nvidia card ?

baoboa ( 2014-12-17 11:08:55 +0000 )edit

@baoboa: It is a newer card. It's a GTX 660 Ti.

jflory7 ( 2014-12-17 11:59:00 +0000 )edit

There's probably some nvidia stuff still active. If you can boot to a CLI, try this, as root: yum remove \*nvidia\* as that will get rid of all of it.

sideburns ( 2014-12-17 19:06:49 +0000 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-17 14:00:07 +0000

look at http://fedoraproject.org/wiki/How_to_debug_Systemd_problems fro debuging

add systemd.log_level=debug in the kernel boot option ( edit one entry at grub menu level)

edit flag offensive delete link more

Comments

Adding that boot parameter to the kernel made no change in the information that is displayed during boot. Any other ideas?

jflory7 ( 2014-12-17 18:57:21 +0000 )edit

did you try another kernel version ?

baoboa ( 2014-12-18 23:46:10 +0000 )edit

check if a usb live of fedora21 is working properly with your hardware

baoboa ( 2014-12-18 23:48:43 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-12-17 03:09:09 +0000

Seen: 950 times

Last updated: Dec 17 '14