Ask Your Question
0

How do I reinstall / activate the Nouveau drivers?

asked 2014-12-17 06:29:58 -0500

padraic gravatar image

updated 2014-12-17 09:48:29 -0500

Hi,

I have a dell optimus enabled laptop running Fedora 21. I want to use a second monitor and so want to enable the noveau drivers.

According to everything I have read the drivers should be installed in Fedora by default. Freedesktop does list package availability for other distributions but not Fedora.

I messed around with installing the nvidia drivers previously and think I may have removed them.

# modprobe noveau

results in

modprobe: FATAL: Module noveau not found.

I have checked my grub cfg and cannot find anywhere I blacklisted them

my /etc/default/grub file is as follows:

GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
#GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root vconsole.keymap=uk rhgb quiet "
#GRUB_DISABLE_RECOVERY="true"
GRUB_THEME="/boot/grub2/themes/system/theme.txt"

I have also checked for possible blacklisting in /etc/modprobe.d and /usr/lib/modprobe.d but haven't had any luck. A fresh install of Fedora 21 might solve this problem but I don't want to have to recompile / reinstall software, messa round with settings again.

edit retag flag offensive close merge delete

Comments

3

it's "nouveau" from french word new

baoboa gravatar imagebaoboa ( 2014-12-17 08:01:35 -0500 )edit

Unless you blacklist it, nouveau should load automatically. What indications do you have that it isn't loading or working?

randomuser gravatar imagerandomuser ( 2014-12-17 10:25:36 -0500 )edit

I don't have enough point s to close this thread, can someone do so?

padraic gravatar imagepadraic ( 2014-12-18 07:00:11 -0500 )edit

@padraic you marked the correct answer, that's all you need to do.

randomuser gravatar imagerandomuser ( 2014-12-18 10:25:05 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-12-17 13:21:20 -0500

updated 2014-12-17 13:48:26 -0500

1) As baoboa writes, you spelled "nouveau" incorrectly, which is why modprobe could not find it.

2) To determine whether or not nouveau is currently loaded on your system, execute lsmod | grep nouveau. If you don't get any results, it's not loaded. If you do get a result, it is loaded.

3) If you did blacklist the driver, you need to check your *.conf files in /etc/modprobe.d to find the file containing the blacklisting directive so that you can remove it. For a quick check, try executing grep nouveau /etc/modprobe.d/* - if you don't get any results, you likely have not blacklisted nouveau and it should load automatically (again, as randomuser mentions).

edit flag offensive delete link more

Comments

Can't believe it was all down to a misspelling but you're correct, that's all it was.

padraic gravatar imagepadraic ( 2014-12-17 14:04:56 -0500 )edit

@baoboa actually pointed that out first, but yeah, that'll do it!

bitwiseoperator gravatar imagebitwiseoperator ( 2014-12-17 15:17:38 -0500 )edit

I have the same issue. I followed the points 2 and 3, and I get nothing in both of them.

InjenieroBarsa gravatar imageInjenieroBarsa ( 2014-12-18 18:46:21 -0500 )edit
1

answered 2014-12-19 08:38:03 -0500

jayaura gravatar image

Another solution which worked for me (for connecting a projector) was to use bumblebee.

Install bumblebee from the repository. Once you make sure that you are running on i915 driver rather than nouveau, your second display should be detected automatically.

edit flag offensive delete link more

Comments

Hi Jayaura, can you give me more details about this? what is the i915 driver?

padraic gravatar imagepadraic ( 2014-12-21 07:16:54 -0500 )edit

i915 is the kernel graphics driver if you are using an intel based hardware. If you have a discreete card, which you do, make sure that it is having the nvidia's optimus functionality. Some old cards dont have it. Cross check with your model version at Nvidia 's website. If it is supported, then you may get lucky with this method. So if your card supports optimus, it means that your can choose to switch off ur discreete card and use only the integrated intel graphics. Now you ready to installall a software called bumblebee which does just that. So install it, make sure that your discreete card is turned off. Now plugin in hte second monitor.

jayaura gravatar imagejayaura ( 2014-12-22 02:14:15 -0500 )edit

oh ok, I've done that but it doesn't work on my machine (Dell xps 15) - the discrete card is the only one hooked up to the hdmi output

padraic gravatar imagepadraic ( 2014-12-27 09:20:34 -0500 )edit
0

answered 2019-03-27 06:48:06 -0500

1.Go to /etc/modprobe.d 2.NVDI creates blacklist nvidia-installer-disable-nouveau.conf file at the time of installation,which also block nouveau. so need to update this file. 3.open above named file and delete "blacklist nouveau" this line.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-17 06:29:58 -0500

Seen: 23,486 times

Last updated: Dec 19 '14