Ask Your Question
5

updating adobe flash (firefox) [closed]

asked 2014-12-18 12:55:30 -0500

bry6673 gravatar image

updated 2015-03-06 23:19:44 -0500

mether gravatar image

I recently noticed that any flash content in firefox has been disabled with the following message: "This plugin is vulnerable and should be updated."

When I click "Check for Updates", it brings me to Mozilla's "Check Your Plugins" page and shows that Adobe Flash is update to date (green with a thumbs up). My only option is to manually allow the outdated plugin to work for each website.

I have also gone to the "Get Adobe Flash" site and chosen YUM for Linux. The install fails beacuse it says the package is already installed.

What am I doing wrong? How do I update adobe flash?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by davidva
close date 2016-04-14 13:49:10.324035

6 Answers

Sort by » oldest newest most voted
7

answered 2015-03-05 11:03:05 -0500

sergiomb gravatar image

updated 2016-02-04 19:05:28 -0500

davidva gravatar image

Since Firefox 35 you can use freshplayer plugin with pepper-flash from chrome :

Import gpgkey of postinstaller packages:

rpm --import https://raw.githubusercontent.com/kuboosoft/postinstallerf/master/GPG/$(rpm -E %fedora)/RPM-GPG-KEY-postinstallerf

And use postinstaller repos also make sure that have mesa-libGLES installed :

dnf --repofrompath abc,https://sourceforge.net/projects/postinstaller/files/fedora/releases/$(rpm -E %fedora)/$(uname -m)/ install chromium-pepper-flash freshplayerplugin mesa-libGLES

and if flash plugin doesn't show up or version is not updating [1]

exit firefox
rm ~/.mozilla/firefox/*/pluginreg.dat
start firefox again

[1] http://unix.stackexchange.com/questio...

edit flag offensive delete link more

Comments

2
davidva gravatar imagedavidva ( 2016-01-17 20:43:58 -0500 )edit
2

you have a package review for freshplayerplugin here : https://bugzilla.rpmfusion.org/show_b... and chromium-pepper-flash is part of goggle-chrome ( rpm -ql google-chrome-beta | grep -i pepper ) /opt/google/chrome-beta/PepperFlash/libpepflashplayer.so /opt/google/chrome-beta/PepperFlash/manifest.json

sergiomb gravatar imagesergiomb ( 2016-01-17 23:12:44 -0500 )edit

It works on Fedora 24, FF 47. You might need to add free fusion as well.

dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
hpop gravatar imagehpop ( 2016-08-03 18:20:49 -0500 )edit
1

now avaiable in rpmfusion , with rpmfusion we need install google-chrome because it needs PepperFlash , /opt/google/chrome-beta/PepperFlash/libpepflashplayer.so

sergiomb gravatar imagesergiomb ( 2016-08-04 05:11:04 -0500 )edit
1

This is now even simpler:

  • remove Adobe's Flash player (if installed): sudo dnf remove flash-plugin
  • install freshplayerplugin from RPMFusion: sudo dnf install freshplayerplugin
  • download the standalone Pepper Flash plugin from https://get.adobe.com/flashplayer/oth... (Choose Linux 64-bit, FP 22.0 (or later) for other Linux 64-bit, PPAPI) as ~/flash_player_ppapi_linux.x86_64.tar.gz
  • extract its contents:

    • sudo mkdir -p /usr/lib64/chromium-browser/PepperFlash
    • cd /usr/lib64/chromium-browser/PepperFlash
    • sudo tar -xf ~/Apps/flash_player_ppapi_linux.x86_64.tar.gz
tjanez gravatar imagetjanez ( 2016-08-11 03:34:47 -0500 )edit
1

answered 2014-12-18 15:27:00 -0500

cobra gravatar image

If you're using the latest updates, and have flash installed using the 'YUM' option from the adobe website, then you already have the latest available genuine flash player. There may be an update to your browser than helps - I got that error for the last week before I did the upgrade to Fedora 21, and it's gone away now.

If you're really concerned, then there are open source alternatives to the Adobe flash player - take a look through your package manager.

edit flag offensive delete link more
0

answered 2015-03-04 16:34:42 -0500

JonB gravatar image
edit flag offensive delete link more
0

answered 2014-12-18 15:46:23 -0500

ccd gravatar image

I ran into this same problem. The solution for me was to download the tar file version.
Installing using the plugin tar.gz:

Unpack the tar.gz file. Once unpacked you will see the following:
    libflashplayer.so
    /usr
Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
Copy libflashplayer.so to the appropriate browser plugins directory. At the prompt type:
    $ cp libflashlayer.so <BrowserPluginsLocation>
Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type:
    $ sudo cp –r usr/* /usr

Then open Firefox and verify the plugin is enabled.

edit flag offensive delete link more
0

answered 2015-03-04 22:24:46 -0500

The adobe repository has the update should work.

Have you tried reinstalling? sudo yum -y reinstall flash-plugin --nogpgcheck

edit flag offensive delete link more
0

answered 2015-07-01 11:51:48 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

The solution for me was this two commands
1) yum search adobe 
    Found the package named  flash-plugin.x86_64 : Adobe Flash Player 11.2
2) yum update flash-plugin.x86_64 

thats it and Dont forget to restart firefox :)
edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-12-18 12:55:30 -0500

Seen: 23,272 times

Last updated: Feb 04 '16