English
Ask Your Question
1

F21 32 bit keeps going into hibernation every minute

asked 2014-12-22 21:01:20 +0000

malak1 gravatar image

updated 2014-12-22 21:51:26 +0000

mether gravatar image

the 32bit image of F21, r5 keeps on going into hibernation every minute or so on my acer aspire one netbook. During the install it was very difficult to babysit the system. The system "works well" now but fixing the constant going into hibernation makes it exceptionally difficult to do anything.

How do you stop this automatic hibernation every minute?

edit retag flag offensive close merge delete

Comments

a bit of background: I had installed the xfce spin and it was stable, without the problem of the system going into hibernation mode after a minute or so. No, I am not closing the clamshell.

malak1 ( 2014-12-23 04:14:30 +0000 )edit

I have reformatted with the XFCE spin, and I tried to swap in the workstation through the command line and yum. unfortunately it didn't work well and just hangs ... then while hung, it went into hibernation.

I am now reinstalling the XFCE spin, and I am very disappointed because the workstation is what I would like to install. Clearly, it installs, and clearly, beyond going into hibernation in less then a minute, and repetitively so after being reawakened, workstation otherwise works on the system (well, best I can tell).

Will the livecd be re-released with this problem left out?

malak1 ( 2014-12-23 17:20:57 +0000 )edit

You can do tests and get logs without interference with systemd-inhibit - ie sudo systemd-inhibit bash. The system won't suspend or hibernate until you end the process invoked with systemd-inhibit.

randomuser ( 2014-12-23 22:29:57 +0000 )edit

great, I'll try that!

Thanks

malak1 ( 2014-12-24 00:25:14 +0000 )edit

I have reinstalled F21 workstation, which is what Iwouldlike to have on the system.

Unfortunately the systemd-inhibit bash command doesn't work, the system keeps on going to sleep, and wakes up right away when I hit any key and resumes where it had been a moment before.

With my "brother in the know" I will be using the XFCE live CD in live mode to mount the hard drive and try to disable the suspend functions.

Further note: This machine has had most versions of Fedora from F11 to F19 and this has never been an issue yet.

Thank you!

malak1 ( 2014-12-24 02:00:13 +0000 )edit

4 answers

Sort by ยป oldest newest most voted
0

answered 2015-07-04 20:58:59 +0000

MKas gravatar image

I have Zoostorm netbook and F22 32bit same problem

edit flag offensive delete link more
0

answered 2015-01-25 18:49:34 +0000

girlintrouble gravatar image

Can anyone add to the babysitting idea, Im moving the mouse and hitting keys to select options and it still goes into suspend.So hibernating in less than a minute of inactivity Im on a Toshiba Satelite Pro. I donrt have a CD either. I successfully installed F20 prior but was having sound issues. I can therefore assume my HW is fine

edit flag offensive delete link more

Comments

My use of the word "babysitting" literally meant to sit in front of the computer and hit keys to wake up the computer every time it went into hibernation. During the install, I couldn't count the number of times I did that since it took probably half an hour to install this way -- so 30, 40 times of hitting the keyboard?

malak1 ( 2015-02-19 18:29:46 +0000 )edit
0

answered 2014-12-23 18:31:19 +0000

jmt gravatar image

I'm just guessing, but it feels like the system thinks that the battery is almost empty and because of that does the right thing in that situation. I'm not sure which software component is handling this situation but anyway, there seems to be a bug that happens to manifest on your particular environment.

edit flag offensive delete link more

Comments

In this particular case, the battery is physically out of the machine and it's running purely on mains electricity. However, I'll try plugging in the battery and reinstall.

Thanks for the suggestion / perspective!

malak1 ( 2014-12-23 22:25:44 +0000 )edit

I'Ve just tried the live-cd for workstation with the battery in and fully charged (over 1hr capacity) and things are still the same.

Thanks for the suggestion though!

malak1 ( 2014-12-23 22:43:05 +0000 )edit
0

answered 2014-12-26 01:12:20 +0000

malak1 gravatar image

The problem seems to have been fixed by:

  • install F21 32bit workstation, by babysitting the system throughout the whole install to keep waking it up every minute or so (literally!)
  • reboot using a live-dvd that works on the system, such as the F21 XFCE live-DVD
  • mount the hard drive (not really sure specifically how my brother did it but using Thunar seemed to help out a lot)
  • open a terminal session and make sure the hard drive is mounted
  • edit the file /etc/systemd/logind.conf
  • uncomment the settings for "HandleSuspendKey" and "HandleLidSwitch"
  • set the "HandleSuspendKey" and "HandleLidSwitch" options to "ignore"
  • save the file
  • reboot
  • enjoy

My system is not happily doing a yum update, which it couldn't do before.

edit flag offensive delete link more

Comments

I followed the procedure outlined above (set both "HandleSuspendKey" and "HandleLidSwitch" to "ignore" in /etc/systemd/logind.conf), and I can confirm that it fixed the same problem on my Acer Aspire One.

oavaldezi ( 2015-01-07 20:32:34 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2014-12-22 21:01:20 +0000

Seen: 1,432 times

Last updated: Jul 04 '15