Ask Your Question
1

touchpad scolling doesn't work

asked 2014-12-26 09:47:23 -0500

ant2009 gravatar image

Hello,

I have installed Fedora 21 on my notebook Asus UX303LN Zenbook

I am running Fedora with the latest updates:

linux localhost.localdomain 3.17.7-300.fc21.x86_64 #1 SMP Wed Dec 17 03:08:44 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

The touchpad left and right clicks works ok. And I can double tap on the touchpad to highlight a sentence. If I try and perform 2 or 3 finger scrolling, all that happens is the mouse pointer moves.

This very is annoying as I normally use the 2 finger scrolling to browse the internet, ebooks, and documents.

Under Settings | Mouse & Touchpad All I have is properties for primary button, double click, and pointer speed.

Has anyone else experienced problems with their touchpad scrolling.

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 064e:9700 Suyin Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and

lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:04.0 Signal processing controller: Intel Corporation Device 0a03 (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation 8 Series Thermal (rev 04)
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 6b)
03:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)

Many thanks for any suggestions.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-01-14 13:43:11 -0500

Paulf gravatar image

Only just updated my laptop. I too have touchpad issues. Two finger scrolling is OK but edge scrolling does not work!

I fix it using

[]$ synclient VertEdgeScroll=1
[]$ synclient HorizEdgeScroll=1

but I have to issue these everytime I log on. I am looking for a better solution. Yours was just the first hit on my search.

Settings before I issue the commands are:

[]$ synclient -l
Parameter settings:
    LeftEdge                = 1773
    RightEdge               = 5471
    TopEdge                 = 1665
    BottomEdge              = 4829
    FingerLow               = 25
    FingerHigh              = 30
    MaxTapTime              = 180
    MaxTapMove              = 248
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 282
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 113
    HorizScrollDelta        = 113
    VertEdgeScroll          = 0
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 1
    HorizTwoFingerScroll    = 1
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0353482
    TouchpadOff             = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 0
    RBCornerButton          = 0
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 0
    TapButton2              = 0
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 1
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice         = 0
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 28
    VertHysteresis          = 28
    ClickPad                = 0
edit flag offensive delete link more

Comments

1

I think I have found the real answer for our problem. Issue the command:

[]$gsettings set org.gnome.settings-daemon.peripherals.touchpad scroll-method 'edge-scrolling'

I am now working without problems.

As an alternative you can use the dconf editor gui. This shows more options which could work for you, including replacing 'edge-scrolling' in my example with 'two-finger-scrolling'. Seems a shame but you don't appear to be able to configure both without the use of synclient. Just another example of gnome stopping us making best use of our hardware.

Paulf gravatar imagePaulf ( 2015-01-14 14:35:25 -0500 )edit

@Paulf, Thanks for your suggestion. However, when I run the following command:
sudo synclient VertEdgeScroll=1 Couldn't find synaptics properties. No synaptics driver loaded? Maybe my Asus uses a different mouse driver. However, I don't know what? Many thanks for any other suggestions

ant2009 gravatar imageant2009 ( 2015-01-15 10:37:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-26 09:47:23 -0500

Seen: 1,108 times

Last updated: Jan 14 '15