English
Ask Your Question
0

How to restart gnome-shell 3.14

asked 2014-12-28 13:47:53 +0000

padraic gravatar image

I use Fedora 21.

Trying Alt+F2 and then r, rl or restart doesn't work for me. I just get a 'command not found' error. Any suggestions on how to restart the shell, or to troubleshoot what I am currently trying?

edit retag flag offensive close merge delete

Comments

Please create a new user and see if alt +f2 and then r works for you. it's worked for me throughout gnome3 and still does.

FranciscoD_ ( 2014-12-29 22:13:16 +0000 )edit

Thanks Francisco, I set up another user and this did work. I must have somehow changeed the setup in my main user's gnome-shell. I will accept an answer here and try to troubleshoot this elsewhere.

padraic ( 2014-12-30 20:04:17 +0000 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2014-12-28 17:30:13 +0000

skytux gravatar image

Try from command line:

$ killall -HUP gnome-shell

It could be from gnome-terminal or switching to TTY2 (Ctrl + Alt + F2).

HTH,

Germán.

edit flag offensive delete link more

Comments

this didn't work for me, either as myself or with sudo.

padraic ( 2014-12-29 16:20:33 +0000 )edit

No need to use sudo. You mean that the command above doesn't restart gnome-shell? In my case it works fine from terminal or even from tty.

skytux ( 2014-12-29 19:49:46 +0000 )edit

No need to vote negative if it doesn't work for you. I posted because it works for me and I wanted to help!!

skytux ( 2014-12-30 01:20:58 +0000 )edit

I didn't vote at all actually, that was someone else. Thanks for your help on this.

When I retried it this did work, not sure what happened the first time.

padraic ( 2014-12-30 19:59:39 +0000 )edit

It wasn't directed specifically at you :) I'm glad it worked!

skytux ( 2014-12-30 22:45:44 +0000 )edit
1

answered 2014-12-29 10:53:43 +0000

deadrat gravatar image

updated 2014-12-30 05:19:06 +0000

There are quite a few ways to restart the GNOME shell. But I haven't tried them all. Alt + F2 and r always works for me. But you may try these.

1, The easier way. Press Alt and F2 together and type r ( it is the best method - is the gnome-shell way of doing things. Thanks @FranciscoD_ )

2, Open the terminal, then type sudo /etc/init.d/gdm restart .

3, Open the terminal, then type sudo killall gnome-panel

4, Press these keys together : Ctrl Alt Backspace. It will restart the Gnome instantly in almost no time. ( It is not working in 3.14 or later, so may not work in Fedora 21. )

If these doesn't work and if you want to restart the display manager itself, type sudo service gdm restart in terminal.

Or maybe you can do this: Ctrl + Alt + F1, login as same user and execute: sudo pkill -9 ^gnome-shell And return back with Ctrl + Alt + F7.

edit flag offensive delete link more

Comments

I'd suggest alt f2 followed by r as the first solution since it doesn't cause any loss of work and is the gnome-shell way of doing things. All the other methods you've listed will probably kill the current use session and cause the currently logged in user to lose their current work/windows.

FranciscoD_ ( 2014-12-29 22:15:54 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2014-12-28 13:47:53 +0000

Seen: 19,874 times

Last updated: Dec 30 '14