Ask Your Question
0

Fedora 21 slow to boot

asked 2014-12-29 17:03:50 -0500

updated 2014-12-29 21:56:41 -0500

skytux gravatar image

Hi,

I've noticed that since upgrading to Fedora 21 that it take longer to boot. The main culprits would appear to be (according to systemd-analyze blame):

19.133s systemd-fsck@dev-mapper-fedora\x2dhome.service
9.325s mandb.service
7.845s dnf-makecache.service

This seems slightly unnecessary, does dnf and mandb really need to run on everyboot? Surely cron is a more logical place to run this type of activity?

fsck I can sorta understand, though, still, on every boot again seems a little over the top.

Any ideas on how to speed things up on boot would be great.

Thanks, Jon

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-12-29 17:14:58 -0500

booting shouldn't wait for dnf-makecache or mandb, only the fsck. If that happens every time, it might be for a reason :P

edit flag offensive delete link more

Comments

I know that systemd tries to do as much as possible in parallel. It's possible that those two services are simply waiting for fsck to complete. Try using systemd-analyze critical-chain and see if either of those services depends on the fsck.

sideburns gravatar imagesideburns ( 2015-01-01 17:31:11 -0500 )edit
0

answered 2015-01-01 16:58:16 -0500

Would appear that mandb service is the main culprit here. No errors, works find, so I've disabled the service and added a cron to perform this functions (which makes more sense to me than doing this on boot).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-29 17:03:50 -0500

Seen: 1,522 times

Last updated: Jan 01 '15