English
Ask Your Question
1

No wired connection after upgrade to 21

asked 2015-01-20 15:07:05 +0000

Ale gravatar image

updated 2015-01-21 02:09:23 +0000

mether gravatar image

Hi all

My wired connection works perfectly before I upgrade to fedora 21. Any idea what can I do?

some more info:

algomez@gomez:~$ ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 0  (Local Loopback)
    RX packets 1463  bytes 129365 (126.3 KiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 1463  bytes 129365 (126.3 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

p8p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet6 fe80::d6be:d9ff:fe45:3b95  prefixlen 64  scopeid 0x20<link>
    ether d4:be:d9:45:3b:95  txqueuelen 1000  (Ethernet)
    RX packets 45878  bytes 4069699 (3.8 MiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 3161  bytes 563326 (550.1 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp8s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.2.140  netmask 255.255.0.0  broadcast 192.168.255.255
    inet6 fe80::c685:8ff:fe5d:efad  prefixlen 64  scopeid 0x20<link>
    ether c4:85:08:5d:ef:ad  txqueuelen 1000  (Ethernet)
    RX packets 1671790  bytes 1342409840 (1.2 GiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 706421  bytes 134031168 (127.8 MiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

algomez@gomez:~$ systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
Active: active (running) since Mon 2015-01-19 23:10:15 EST; 18h ago
Main PID: 882 (NetworkManager)
CGroup: /system.slice/NetworkManager.service
       ├─  882 /usr/sbin/NetworkManager --no-daemon
       ├─ 5874 /sbin/dhclient -d -q -sf /usr/libexec/nm-dhcp-helper -pf /var/run/dhclient-wlp8s0.pid -lf /var/lib/NetworkManager/dhclient-30f183b6-4896-4b47-89ef-a5281e59bf75-wlp8s0.l...
       └─28016 /sbin/dhclient -d -q -sf /usr/libexec/nm-dhcp-helper -pf /var/run/dhclient-p8p1.pid -lf /var/lib/NetworkManager/dhclient-82b0ad59-2cac-4b0e-8a4c-c8eb9de764c3-p8p1.lease...

Jan 20 17:48:28 gomez.physics.rutgers.edu NetworkManager[882]: <info>  Activation (p8p1) Stage 3 of 5 (IP Configure Start) started...
Jan 20 17:48:28 gomez.physics.rutgers.edu NetworkManager[882]: <info>  (p8p1): device state change: config -> ip-config (reason 'none') [50 70 0]
Jan 20 17:48:28 gomez.physics.rutgers.edu NetworkManager[882]: <info>  Activation (p8p1) Beginning DHCPv4 transaction (timeout in 45 seconds)
Jan 20 17:48:28 gomez.physics.rutgers.edu NetworkManager[882]: <info>  dhclient started with pid 28016
Jan 20 17:48:28 gomez.physics.rutgers.edu NetworkManager[882]: <info>  Activation (p8p1) Stage 3 of 5 (IP Configure Start) complete.
Jan 20 17:48:28 gomez.physics.rutgers.edu NetworkManager[882]: <info>  (p8p1): DHCPv4 state changed nbi -> preinit
Jan 20 17:48:28 gomez.physics.rutgers.edu dhclient[28016]: DHCPDISCOVER on p8p1 to 255.255.255.255 port 67 interval 5 (xid=0x56fe1fc)
Jan 20 17:48:33 gomez.physics.rutgers.edu dhclient[28016]: DHCPDISCOVER on p8p1 to 255.255.255.255 port 67 interval 13 (xid=0x56fe1fc)
Jan 20 17 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
1

answered 2015-01-21 13:13:12 +0000

Colossus gravatar image

Your system seems to ask for an IP address (DHCPDISCOVER) and doesn't get one. Probably it's this bug: http://fedoraproject.org/wiki/Common_F21_bugs#Network_issues (IP address discovery via DHCP does not work).

Solution: create a file /etc/dhcp/dhclient.conf with this one line:

send dhcp-client-identifier = hardware;
edit flag offensive delete link more

Comments

thank you SOOOO much... I just add this line and immediately I could connect!!! THANKS!!!

Ale ( 2015-01-21 15:23:40 +0000 )edit
1

answered 2015-01-20 21:00:27 +0000

deusdara gravatar image

Hi

  1. Go to gnome control panel ( all settings)
  2. Select network then wired
  3. Click the button on the bottom right
  4. Select identity and tick the box connect automatically you should now be able to connect automatically to internet.
edit flag offensive delete link more

Comments

thanks, but of course this does not work. It does not connect automatically.

Ale ( 2015-01-20 23:04:30 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2015-01-20 15:07:05 +0000

Seen: 1,432 times

Last updated: Jan 21 '15