Ask Your Question
0

gnome-shell very high cpu usage on a clean install F21

asked 2015-01-25 09:53:17 -0600

David-- gravatar image

updated 2015-04-01 18:45:04 -0600

mether gravatar image

I've just installed fedora 21 and gnome-shell is constantly on 35-60% of my cpu (using a thinkpad T400 with a c2d P8600).

glxinfo | grep OpenG
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset 
OpenGL version string: 2.1 Mesa 10.4.1
OpenGL shading language version string: 1.20
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 10.4.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions

$ lspci | grep -i vga

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

What can I do? This takes my battery life from 6 hours on Debian to 2 hours on Fedora

edit retag flag offensive close merge delete

Comments

I have the same problem. Laptop Dell E6400, however CPU usage is 21-23% constantly. I had it on fedora 20 and 21.

Sergey gravatar imageSergey ( 2015-03-03 14:08:09 -0600 )edit

What Kernel version are you using? Have you tried installing the Intel graphics drivers ( https://01.org/linuxgraphics/ )? Also, have you looked into installing TLP and the Thinkpad TLP add-ins ( http://linrunner.de/en/tlp/tlp.html )? Just a thought.

idrodebush gravatar imageidrodebush ( 2015-03-03 15:25:59 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-03-25 12:21:44 -0600

Joris gravatar image

I've had this problem as well. My solution was to disable the extention "Background Logo", which draws the fedora logo on top of your background. This extention doesn't seem to work well with Intel GM cards.

My CPU usage is back to 2% right now.

To disable the extention: Install gnome-tweak-tool

sudo yum install gnome-tweak-tool

Start the tweak tool and disable the extention "Background Logo" in the overview "Extentions"

edit flag offensive delete link more

Comments

Same here, this fixed the issue with my MacBook Pro (mid 2014).

mtoh gravatar imagemtoh ( 2015-03-30 10:12:34 -0600 )edit
0

answered 2015-03-03 15:19:27 -0600

Sergey gravatar image

I managed to fix the problem by installing proprietary drivers for my videocard (NVidia in my case). Now gnome-shell does not eat any CPU when idle.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-25 09:53:17 -0600

Seen: 6,539 times

Last updated: Mar 25 '15