Ask Your Question
0

Problem with installing Nvidia 740m driver on Fedora 21

asked 2015-02-09 22:33:34 -0500

Roham Soroush gravatar image

updated 2015-02-10 08:40:49 -0500

mether gravatar image

I had tried many ways. But unfortunately did not succeed. first method.: I downloaded graphics card drivers from the Nvida websit ==> NVIDIA-Linux-x86_64-346.35

First of all, I was out of the X with

ctrl+alt+f2

After that I getting root access. Also, I used init3 to put out the X.

I went to the folder where the Nvidia driver was. I used the following command.

‫‪Chmod‬‬ ‫‪+x‬‬ ‫‪NVIDIA-Linux‬‬

and

NVIDIA-Linux-x86_64-346.35.run/.

Installation was complete. I used the following commands before rebooting.

ٰmv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

and:

dracut /boot/initramfs-$(uname -r).img $(uname -r)

But after reboot and boot the system facing up. with the image

image description

I had to remove the driver has everything get back to the initial state.

sudo yum remove *\nvidia\*

The next method I used was the yum and RPM Fusion repositories like this:

yum install akmod-nvidia "kernel-devel-uname-r == $(uname -r)"

and:

yum update -y

Finally, reboot the system, I still deal with the following message:

something has gone wrong

And again, I had to remove all files installed.

Systems Information:

Linux localhost.localdomain 3.18.5-201.fc21.x86_64 #1 SMP Mon Feb 2 21:00:58 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I followed this site:

http://rpmfusion.org/Howto/nVidia#In...ng_the_drivers )

and this site too:

( http://elrepo.org/tiki/kmod-nvidia )

Well I've done it this :

yum install akmod-nvidia-304xx "kernel-devel-uname-r == $(uname -r)"

and then this too:

yum update -y

after I that I just reboot the system and when system boot faced with a black screen with this messages on screen:

[drm:cpt_set_fifo_underrun_reporting]_ *ERROR* uncleared pch fifio underrun on pch transcoder A

[drm:cpt_serr_int_int_handler] *ERROR* PCH transcoder  FIFO underrun

After that, I checked the ctrl+alt+f2 and I do not have access to the terminal.

edit retag flag offensive close merge delete

Comments

Are you using a laptop with two GPU from different GPU (something like a combo nVidia GPU + Intel IGPU)?

Dremor gravatar imageDremor ( 2015-02-15 19:16:59 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-01-08 05:19:17 -0500

lynxcode gravatar image

{yum install akmod-nvidia-304xx "kernel-devel-uname-r == $(uname -r)"} please check with nvidia download helper with nvidia site. 7/8 label is not 700/800. It's mean 7000/8000. I think 304xx packages for very old devices.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-09 22:33:34 -0500

Seen: 227 times

Last updated: Jan 08