Ask Your Question
0

no wifi and bluetooth option showing

asked 2015-03-21 08:09:08 -0600

abhishek1309 gravatar image

after installing fedora 20 no wifi, bluetooth and hotspot option is showing

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2015-03-21 09:47:32 -0600

dejan gravatar image

updated 2015-03-21 09:48:44 -0600

I do not remember when it was but in one of recent Fedora releases they have separated wifi part of NetworkManager into a package. I think package name is NetworkManager-wifi (frankly, I was pissed off because of this as the new package is not installed by default, and I had no idea why I could not see Wifi networks in NetworkManager). Once I installed that package it all appeared.

As a workaround, you may try iwconfig and similar set of command-line tools.

edit flag offensive delete link more
0

answered 2015-03-21 10:05:51 -0600

ddkroyal001 gravatar image

open terminal and check For bluetooth: $ systemctl status bluetooth.service

if it is disable then enable it

$ systemctl enable bluetooth.service $ systemctl start bluetooth.service

Same thing for network check NetworkManager.service, ModemManager.service if it is inactive (dead) make it enable and start the service.

after doing all it is better to reboot and recheck again.

I have face this problem for bluetooth

For wifi check Check the driver status $ lspci -k First you need to find the name of wireless interface. You can do it with following command: $ iw dev To check link status, use following command. Example output when not connected to an AP: $ iw dev wlan0 link and for more information for wifi https://wiki.archlinux.org/index.php/Wireless_network_configuration.

edit flag offensive delete link more
0

answered 2015-03-22 01:39:45 -0600

coffeeking gravatar image

What hardware do you have? Try the following command in a terminal. lspci | grep -i net. This will print only network pci devices. Most embedded wifi and bluetooth chips on motherboards are attached this way. If it's a broadcom anything, that's a messy area for linux, and I won't be of much help, I've always had issues with broadcom or anything that use those chips.

edit flag offensive delete link more

Comments

if it is by any mean broadcam then you can try the noarch repo to install kmod-wl driver it works with broadcom..

linuxarpan gravatar imagelinuxarpan ( 2015-03-22 15:04:55 -0600 )edit
0

answered 2015-03-21 18:54:07 -0600

linuxarpan gravatar image

updated 2015-03-21 18:55:56 -0600

please specify your driver specification ..and output of iwconfig and ifconfig

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-21 08:09:08 -0600

Seen: 719 times

Last updated: Mar 22 '15