Ask Your Question
0

How to disable NCQ in Fedora 21?

asked 2015-03-24 19:30:03 -0500

jwart44 gravatar image

updated 2015-03-24 21:06:52 -0500

mether gravatar image

My SATA chipset has NCQ issues (the dreaded "READ FPDMA QUEUED" error) and to mitigate them I want to disable NCQ as suggested by https://wiki.archlinux.org/index.php/Solid_State_Drives#Resolving_NCQ_Errors .

I tried both ideas given on http://www.audiodude.nl/?p=796 but my dmesg output still contains

ata3.00: [...], multi 1: LBA48 NCQ (depth 31/32), AA

indicating that NCQ is on per http://forums.fedoraforum.org/showthread.php?t=155584 . Additionally, /sys/block/sda/device/queue_depth defaults back to 31 on every restart, even after running

echo 1 > /sys/block/sda/device/queue_depth


How do I permanently disable NCQ in Fedora 21?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-02 15:50:45 -0500

spot gravatar image

Assuming that setting the drive queue_depth to 1 resolves your issue, you should be able to do this with the tmpfiles.d component in systemd.

Make a new .conf file in /etc/tmpfiles.d, lets call it /etc/tmpfiles.d/noncq.conf. Inside it, put this line:

w /sys/block/sda/device/queue_depth - - - - 1

man tmpfiles.d will explain that syntax in depth, but essentially, we're teling tmpfiles.d to write a 1 to that file.

When you reboot, it should take effect.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-03-24 19:30:03 -0500

Seen: 429 times

Last updated: Apr 02 '15