English
Ask Your Question
1

Disable touchpad while typing on GNOME (Fedora 22)

asked 2015-04-02 12:17:10 +0000

guss77 gravatar image

I'm using Fedora 22 (branched) with GNOME 3.16 on a Dell laptop with a ALPS touchpad. I was previously using KDE and that has - in the touchpad settings KCM - an option to "disable touchpad while typing". Because I have large hands, I often touch the sides of the touchpad while touch-typing, and that causes the mouse pointer to jerk around and (because I have enabled tap to click) also sometimes click on and drag things.

I've looked for a similar option to disable the touchpad, but couldn't find any, even in the GNOME tweak tool.

Any idea?

edit retag flag offensive close merge delete

Comments

Hope that @cgnoz31's answer helps you, it looks good to me (I can confirm the setting is there on my 3.14 setup) but please check https://ask.fedoraproject.org/en/ques...

jcuenod ( 2015-04-02 20:54:16 +0000 )edit

8 answers

Sort by ยป oldest newest most voted
2

answered 2015-06-04 22:18:02 +0000

whot gravatar image

fwiw, disable-while-typing is available since libinput-0.15.0-3.f22 and it's automatically enabled. There's no toggle for it (yet).

edit flag offensive delete link more
1

answered 2017-01-06 03:51:37 +0000

Om Prakash gravatar image

The key to disable touchpad while typing doesn't exist anymore in the Gnome registry.

First install dconf-editor -

sudo dnf install dconf-editor

then create a key in dconf editor using this command on terminal.

dconf write /org/gnome/desktop/peripherals/touchpad/disable-while-typing true

It will create same key as in Gnome 3.14 and will set it to true.

This worked for me on fedora 23, Gnome 3.18.

edit flag offensive delete link more

Comments

still testing this, but as far as I know now this helps for me. I did write this, without the need to reset the cursor. and the touchpad is still working after typing. (Fedora 25 on Macbook alu 2008)

jaapsoft ( 2017-01-17 14:08:22 +0000 )edit

upstream gnome bug: https://bugzilla.gnome.org/show_bug.c...

whot ( 2017-01-30 23:35:26 +0000 )edit
1

answered 2015-04-02 13:42:27 +0000

cgonz31 gravatar image

This may not be entirely accurate but in Fedora 21 (GNOME 3.14) you can do this:

Press the Super key (i.e. Windows Key)

Type "Settings"

Click on the "Settings" launcher that appears in the search results

Click on "Mouse & Touchpad"

The setting should be in this menu. I can't double check right now as I am using a desktop PC at the moment. But, on my laptop, the setting was here, if I remember correctly.

edit flag offensive delete link more

Comments

This is how the touchpad settings dialog looks in GNOME 3.16 on Fedora 22: http://snag.gy/JgatQ.jpg . I don't see anything about disabling touchpad while typing. Looking at screenshots of previous versions, it looks like there used to be more options there, but they were removed. I've opened a bug for this: https://bugzilla.gnome.org/show_bug.c...

guss77 ( 2015-04-04 15:25:21 +0000 )edit

I did confirm that on my laptop with GNOME 3.14, the checkbox is there. It's labeled "Disable while typing."

cgonz31 ( 2015-04-04 15:59:58 +0000 )edit

Apparently - the missing checkbox in Fedora 22 is a "feature", not a bug: https://fedoraproject.org/wiki/Change... . Still can't get it to work though.

guss77 ( 2015-04-04 16:27:27 +0000 )edit
0

answered 2016-01-04 20:14:45 +0000

updated 2016-01-05 11:05:49 +0000

Its actually configurable for the libinput driver for Xorg even though you can't find any GUI setting for it in Fedora 23 under mouse & touch pad

open the file /usr/share/X11/xorg.conf.d/90-libinput.conf

Under the section for the device with the identifier "libinput touchpad catchall" add the optioons

Option "PalmDetection" "True"
Option "DisableWhileTyping" "true"

Will require a logout to take effect. works great on my touch pad but I have a Macbook so might not work as well for other touchpad devices.

edit flag offensive delete link more

Comments

fwiw, option PalmDetection doesn't exist, so this line has no effect.

whot ( 2016-02-04 05:55:53 +0000 )edit

I was able to use

Option "PalmDetection" "false" Option "DisableWhileTyping" "false"

to enable touchpad whilst typing on Fedora 24 - for gaming when I forget my mouse

jprance ( 2016-11-04 16:55:28 +0000 )edit
0

answered 2016-02-12 17:04:17 +0000

press Fn+F8

edit flag offensive delete link more
0

answered 2015-11-06 08:19:15 +0000

guss77 gravatar image

"Disable touchpad while typing" has been canceled in favor of a "palm detection" feature that is implemented by libinput.

Unfortunately, the later doesn't work very reliably (or at all, depending on your hardware).

But there doesn't seem to be a political way to go back to "disable touchpad while typing" and from my discussions with the libinput developer (as documented in the above link and in email), there is very little libinput developers can do about getting palm detection working reliably enough to be used for work, on some common hardware.

edit flag offensive delete link more

Comments

we've had disable-while-typing in libinput since July 2015 (version 0.21 and later)

whot ( 2015-12-09 05:49:06 +0000 )edit
0

answered 2015-06-03 10:02:18 +0000

cribari gravatar image

I am having this problem with Fedora 22, kernel 4.0.4-303.fc22.x86_64. I do not find the option to disable the touchpad while typing. Suggestions are welcome.

edit flag offensive delete link more
0

answered 2015-04-05 20:52:59 +0000

lsatenstein gravatar image

Fedora 22 is still in Beta mode (tc7). There is an option to disable the touchpad while typing. If it is not working, please report it as a bug to https://bugzilla.redhat.com/

Nothing is more frustrating than having the touchpad active while typing or while an external mouse is connected.

edit flag offensive delete link more

Comments

True that F22 is still in beta, which is the best time to report such usability problem :-) . I've opened several bugs on the subject, the GNOME bug linked in a previous comment, Fedora bugs #1181565 (comment 9) and #1209753. But the gist of it is that GNOME 3.16 doesn't offer "disable touchpad" option at all, and relies on downstream distribution to provide palm detection feature based in libinput. Currently libinput doesn't work as advertised, and even if it did - one might argue that palm detection is not enough and we still need the option of totally disabling the touchpad while typing.

guss77 ( 2015-04-08 07:27:11 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
2 followers

Stats

Asked: 2015-04-02 12:17:10 +0000

Seen: 6,879 times

Last updated: Jan 06