F21 systemd log flood - how to stop

asked 2015-04-05 09:30:26 -0600

whairst gravatar image

I'm having trouble with systemd flooding /var/log/messages with every cron job. I've tried setting LogLevel=emerg in /etc/systemd/system.conf (and ran systemctl daemon-reload, and systemctl daemon-reexec, and rebooted), as well as trying systemd-analyze set-log-level emerg. No effect.

The first time I tried system.conf, I mistakenly put LogLevel=warn. At every boot, I get the error message systemd[1]: [/etc/systemd/system.conf:11] Invalid log level'warn': Operation not permitted But I've changed it from warn to emerg, did daemon-reload, and daemon-reexec, and multiple reboots, and it's still giving me this error.

What I'm seeing for each cron job (hourly, per defaults!) is this:

Apr  5 06:01:01 localhost systemd: Starting Paths.
Apr  5 06:01:01 localhost systemd: Reached target Paths.
Apr  5 06:01:01 localhost systemd: Starting Timers.
Apr  5 06:01:01 localhost systemd: Reached target Timers.
Apr  5 06:01:01 localhost systemd: Starting Sockets.
Apr  5 06:01:01 localhost systemd: Reached target Sockets.
Apr  5 06:01:01 localhost systemd: Starting Basic System.
Apr  5 06:01:02 localhost systemd: Reached target Basic System.
Apr  5 06:01:02 localhost systemd: Starting Default.
Apr  5 06:01:02 localhost systemd: Reached target Default.
Apr  5 06:01:02 localhost systemd: Startup finished in 32ms.
Apr  5 06:01:02 localhost systemd: Stopping Default.
Apr  5 06:01:02 localhost systemd: Stopped target Default.
Apr  5 06:01:02 localhost systemd: Stopping Basic System.
Apr  5 06:01:02 localhost systemd: Stopped target Basic System.
Apr  5 06:01:02 localhost systemd: Stopping Paths.
Apr  5 06:01:02 localhost systemd: Stopped target Paths.
Apr  5 06:01:02 localhost systemd: Stopping Timers.
Apr  5 06:01:02 localhost systemd: Stopped target Timers.
Apr  5 06:01:02 localhost systemd: Stopping Sockets.
Apr  5 06:01:02 localhost systemd: Stopped target Sockets.
Apr  5 06:01:02 localhost systemd: Starting Shutdown.
Apr  5 06:01:02 localhost systemd: Reached target Shutdown.
Apr  5 06:01:02 localhost systemd: Starting Exit the Session...
Apr  5 06:01:02 localhost systemd: Received SIGRTMIN+24 from PID 8219 (kill).

That's everything in /var/log/messages between 5:30 and 6:30. It's the vast majority of my log contents; finding anything else is like finding a pearl in piles of snow. (The Codeless Code, Case 73).

How do I get this to stop?

edit retag flag offensive close merge delete

Comments

mayorga gravatar imagemayorga ( 2015-04-05 12:41:56 -0600 )edit

That's what I'm seeing. Note that it's been unresolved for a year, with no real solutions presented - just hiding them for users of journald. (I'm not using journald.)

whairst gravatar imagewhairst ( 2015-04-05 15:03:51 -0600 )edit