Ask Your Question
0

Google Chrome x86_64 on Fedora 21. . .

asked 2015-04-09 22:22:26 -0500

kamdard gravatar image

updated 2015-10-20 20:53:34 -0500

mether gravatar image

Hi,

I did a fresh install of Fedora 21 Workstation (x86_64) on Acer Aspire 5517. The system is now up-to-date. I installed google-chrome (64 bit) but when I click on the google-chrome icon, nothing happens.

I tried via command-line and get the following error: [kamdard@localhost ~]$ google-chrome /usr/bin/google-chrome: error while loading shared libraries: /lib64/libXss.so.1: file too short [kamdard@localhost ~]$

[kamdard@localhost ~]$ sudo yum -y update; Loaded plugins: langpacks No packages marked for update [kamdard@localhost ~]$

Will appreciate if someone can help me resolve the issue. Here is some additional info from my set-up:

[kamdard@localhost ~]$ cat /etc/redhat-release Fedora release 21 (Twenty One)

[kamdard@localhost ~]$ uname -a Linux localhost.localdomain 3.19.3-200.fc21.x86_64 #1 SMP Thu Mar 26 21:39:42 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux [kamdard@localhost ~]$

[kamdard@localhost ~]$ sudo rpm -qa | grep -i google-chrome [sudo] password for kamdard: google-chrome-stable-41.0.2272.118-1.x86_64 [kamdard@localhost ~]$

[kamdard@localhost ~]$ cat /etc/yum.repos.d/google-chrome.repo [google-chrome] name=google-chrome baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64 enabled=1 gpgcheck=1 [kamdard@localhost ~]$

edit retag flag offensive close merge delete

Comments

When you initially installed google-chrome, did u install it with yum install or rpm -i?

anishjp gravatar imageanishjp ( 2015-04-10 06:26:29 -0500 )edit

I tried both the approaches with the same results.

kamdard gravatar imagekamdard ( 2015-04-10 09:30:40 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-04-10 04:19:44 -0500

pnadk gravatar image

When I try the command ldd /opt/google/chrome/chrome it shows that it does use libXss.so Then the command yum search libxss shows that this library is provided by libXScrnSaver so please try to install that with yum install libXScrnSaver and see if that helps.

edit flag offensive delete link more

Comments

My system tells me that it is already installed: +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ [kamdard@localhost ~]$ sudo yum install libXScrnSaver.x86_64 Loaded plugins: langpacks Package libXScrnSaver-1.2.2-8.fc21.x86_64 already installed and latest version Nothing to do +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

kamdard gravatar imagekamdard ( 2015-04-10 09:30:38 -0500 )edit
0

answered 2015-04-10 16:32:01 -0500

kamdard gravatar image

OK, I resolved the issue by re-installing "libXScrnSaver-1.2.2-8.fc21.x86_64" which created the necessary symlink in /lib64 directory for libXss.so.1 as follows.

[kamdard@gabba lib64]$ ls -ltr libXss* lrwxrwxrwx. 1 root root 15 Aug 17 2014 libXss.so.1 -> libXss.so.1.0.0 -rwxr-xr-x. 1 root root 15496 Aug 17 2014 libXss.so.1.0.0

Thanks for all those who provided pointers and responses. Appreciate your help.

Thanks, DK.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-09 22:22:26 -0500

Seen: 1,438 times

Last updated: Apr 09 '15